%global _empty_manifest_terminate_build 0
Name: python-fuc
Version: 0.36.0
Release: 1
Summary: Frequently used commands in bioinformatics
License: MIT
URL: https://github.com/sbslee/fuc
Source0: https://mirrors.aliyun.com/pypi/web/packages/c3/c5/f5e7f40ce54db8de49d3092345dd9d5f05aba49a8f1c484bb8e5e78e8310/fuc-0.36.0.tar.gz
BuildArch: noarch
Requires: python3-biopython
Requires: python3-lxml
Requires: python3-matplotlib
Requires: python3-matplotlib-venn
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-pyranges
Requires: python3-pysam
Requires: python3-scipy
Requires: python3-seaborn
Requires: python3-statsmodels
%description
The main goal of the fuc package (pronounced "eff-you-see") is to wrap some of the most **f**\ requently **u**\ sed **c**\ ommands in the field of bioinformatics into one place.
The package is written in Python, and supports both command line interface (CLI) and application programming interface (API) whose documentations are available at the `Read the Docs `_.
Currently, fuc can be used to analyze, summarize, visualize, and manipulate the following file formats:
- Sequence Alignment/Map (SAM)
- Binary Alignment/Map (BAM)
- CRAM
- Variant Call Format (VCF)
- Mutation Annotation Format (MAF)
- Browser Extensible Data (BED)
- FASTQ
- FASTA
- General Feature Format (GFF)
- Gene Transfer Format (GTF)
- delimiter-separated values format (e.g. comma-separated values or CSV format)
Additionally, fuc can be used to parse output data from the following programs:
- `Ensembl Variant Effect Predictor (VEP) `__
- `SnpEff `__
- `bcl2fastq and bcl2fastq2 `__
- `Kallisto `__
Your contributions (e.g. feature ideas, pull requests) are most welcome.
| Author: Seung-been "Steven" Lee
| Email: sbstevenlee@gmail.com
| License: MIT License
%package -n python3-fuc
Summary: Frequently used commands in bioinformatics
Provides: python-fuc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fuc
The main goal of the fuc package (pronounced "eff-you-see") is to wrap some of the most **f**\ requently **u**\ sed **c**\ ommands in the field of bioinformatics into one place.
The package is written in Python, and supports both command line interface (CLI) and application programming interface (API) whose documentations are available at the `Read the Docs `_.
Currently, fuc can be used to analyze, summarize, visualize, and manipulate the following file formats:
- Sequence Alignment/Map (SAM)
- Binary Alignment/Map (BAM)
- CRAM
- Variant Call Format (VCF)
- Mutation Annotation Format (MAF)
- Browser Extensible Data (BED)
- FASTQ
- FASTA
- General Feature Format (GFF)
- Gene Transfer Format (GTF)
- delimiter-separated values format (e.g. comma-separated values or CSV format)
Additionally, fuc can be used to parse output data from the following programs:
- `Ensembl Variant Effect Predictor (VEP) `__
- `SnpEff `__
- `bcl2fastq and bcl2fastq2 `__
- `Kallisto `__
Your contributions (e.g. feature ideas, pull requests) are most welcome.
| Author: Seung-been "Steven" Lee
| Email: sbstevenlee@gmail.com
| License: MIT License
%package help
Summary: Development documents and examples for fuc
Provides: python3-fuc-doc
%description help
The main goal of the fuc package (pronounced "eff-you-see") is to wrap some of the most **f**\ requently **u**\ sed **c**\ ommands in the field of bioinformatics into one place.
The package is written in Python, and supports both command line interface (CLI) and application programming interface (API) whose documentations are available at the `Read the Docs `_.
Currently, fuc can be used to analyze, summarize, visualize, and manipulate the following file formats:
- Sequence Alignment/Map (SAM)
- Binary Alignment/Map (BAM)
- CRAM
- Variant Call Format (VCF)
- Mutation Annotation Format (MAF)
- Browser Extensible Data (BED)
- FASTQ
- FASTA
- General Feature Format (GFF)
- Gene Transfer Format (GTF)
- delimiter-separated values format (e.g. comma-separated values or CSV format)
Additionally, fuc can be used to parse output data from the following programs:
- `Ensembl Variant Effect Predictor (VEP) `__
- `SnpEff `__
- `bcl2fastq and bcl2fastq2 `__
- `Kallisto `__
Your contributions (e.g. feature ideas, pull requests) are most welcome.
| Author: Seung-been "Steven" Lee
| Email: sbstevenlee@gmail.com
| License: MIT License
%prep
%autosetup -n fuc-0.36.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fuc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.36.0-1
- Package Spec generated