%global _empty_manifest_terminate_build 0
Name: python-dash-cool-components
Version: 0.1.8
Release: 1
Summary: Cool React components, wrapped for Plotly Dash
License: MIT
URL: https://github.com/Tauffer-Consulting/dash-cool-components
Source0: https://mirrors.aliyun.com/pypi/web/packages/cb/40/d8a8bccd5abeb325142d7ebf1f40d04a2601f6deb3ddd0df4d852cb8fdf8/dash_cool_components-0.1.8-1.tar.gz
BuildArch: noarch
Requires: python3-dash
%description
Dash Cool Components
Cool React components, wrapped for Plotly Dash
[![PyPI version](https://badge.fury.io/py/dash-cool-components.svg)](https://badge.fury.io/py/dash-cool-components)
## Table of contents
- [Installation](#installation)
- [Quick Start](#quickstart)
## Installation
```sh
pip install dash-cool-components
```
## Components
Datetime Picker
A date-time-timezone picker input. Implemented with the [React Datepicker](https://www.npmjs.com/package/react-datepicker) and
[Timezone Picker React](https://www.npmjs.com/package/react-bootstrap-timezone-picker) components.
### Component Properties:
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks. |
| value | string | The input's current value, on ISO format with date, time and timezone. |
| renderTimezone | boolean | Defines if the timezone input should be rendered. Defaults to true. |
| placeholder | string | The date input placeholder. |
| timezonePlaceholder | string | The timezone input placeholder. |
| style | object or string | The component container's style. Can be a style object or a css string. |
| dateInputStyle | object or string | The date input's style. Can be a style object or a css string. |
| timezoneInputStyle | object | The timezone container's style. Must be a style object. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_DateTimePicker.py)
![](images/datetimepicker.gif)
Keyed File Browser
File and directory browser given a flat keyed list of objects. Implemented with
[React Keyed File Browser](https://github.com/uptick/react-keyed-file-browser).
### Component Properties
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks. |
| selectedPath | string | The current selected path in the file tree. |
| files | array | The file tree to be displayed in the browser. Each entry in the array must be an object with the `key` property, which specifies it's location in the tree. Otherproperties are `modified` and `size`. To be able to receive the path selection feedback, you must enter keys for both files and folders. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_KeyedFileBrowser.py)
![](images/filebrowser.gif)
Tag Input
A tag input component. Implemented with [React Tag Input](https://github.com/leekevinyg/react-tag-input).
### Components Properties
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks |
| wrapperStyle | object or string | The component wrapper's style. Can be either a style object or a CSS string. |
| tagStyle | object or string | The tag's style. Can be either a style object or a CSS string |
| inputStyle | object or string | The text input's style. Can be either a style object or a CSS string. |
| tagDeleteStyle | object or string | The tag delete button's style. Can be either a style object or a CSS string. |
| placeholder | string | Placeholder for the text input |
| placeholder | string | Placeholder for the text input |
| value | array | The input's current tags array of objects. e.g [{"index": 0, "displayValue": "Tag"}] |
| injectedTags | array | Tags to be inserted on the input. The input's atual tags are replaced. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_TagInput.py)
![](images/taginput.gif)
%package -n python3-dash-cool-components
Summary: Cool React components, wrapped for Plotly Dash
Provides: python-dash-cool-components
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dash-cool-components
Dash Cool Components
Cool React components, wrapped for Plotly Dash
[![PyPI version](https://badge.fury.io/py/dash-cool-components.svg)](https://badge.fury.io/py/dash-cool-components)
## Table of contents
- [Installation](#installation)
- [Quick Start](#quickstart)
## Installation
```sh
pip install dash-cool-components
```
## Components
Datetime Picker
A date-time-timezone picker input. Implemented with the [React Datepicker](https://www.npmjs.com/package/react-datepicker) and
[Timezone Picker React](https://www.npmjs.com/package/react-bootstrap-timezone-picker) components.
### Component Properties:
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks. |
| value | string | The input's current value, on ISO format with date, time and timezone. |
| renderTimezone | boolean | Defines if the timezone input should be rendered. Defaults to true. |
| placeholder | string | The date input placeholder. |
| timezonePlaceholder | string | The timezone input placeholder. |
| style | object or string | The component container's style. Can be a style object or a css string. |
| dateInputStyle | object or string | The date input's style. Can be a style object or a css string. |
| timezoneInputStyle | object | The timezone container's style. Must be a style object. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_DateTimePicker.py)
![](images/datetimepicker.gif)
Keyed File Browser
File and directory browser given a flat keyed list of objects. Implemented with
[React Keyed File Browser](https://github.com/uptick/react-keyed-file-browser).
### Component Properties
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks. |
| selectedPath | string | The current selected path in the file tree. |
| files | array | The file tree to be displayed in the browser. Each entry in the array must be an object with the `key` property, which specifies it's location in the tree. Otherproperties are `modified` and `size`. To be able to receive the path selection feedback, you must enter keys for both files and folders. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_KeyedFileBrowser.py)
![](images/filebrowser.gif)
Tag Input
A tag input component. Implemented with [React Tag Input](https://github.com/leekevinyg/react-tag-input).
### Components Properties
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks |
| wrapperStyle | object or string | The component wrapper's style. Can be either a style object or a CSS string. |
| tagStyle | object or string | The tag's style. Can be either a style object or a CSS string |
| inputStyle | object or string | The text input's style. Can be either a style object or a CSS string. |
| tagDeleteStyle | object or string | The tag delete button's style. Can be either a style object or a CSS string. |
| placeholder | string | Placeholder for the text input |
| placeholder | string | Placeholder for the text input |
| value | array | The input's current tags array of objects. e.g [{"index": 0, "displayValue": "Tag"}] |
| injectedTags | array | Tags to be inserted on the input. The input's atual tags are replaced. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_TagInput.py)
![](images/taginput.gif)
%package help
Summary: Development documents and examples for dash-cool-components
Provides: python3-dash-cool-components-doc
%description help
Dash Cool Components
Cool React components, wrapped for Plotly Dash
[![PyPI version](https://badge.fury.io/py/dash-cool-components.svg)](https://badge.fury.io/py/dash-cool-components)
## Table of contents
- [Installation](#installation)
- [Quick Start](#quickstart)
## Installation
```sh
pip install dash-cool-components
```
## Components
Datetime Picker
A date-time-timezone picker input. Implemented with the [React Datepicker](https://www.npmjs.com/package/react-datepicker) and
[Timezone Picker React](https://www.npmjs.com/package/react-bootstrap-timezone-picker) components.
### Component Properties:
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks. |
| value | string | The input's current value, on ISO format with date, time and timezone. |
| renderTimezone | boolean | Defines if the timezone input should be rendered. Defaults to true. |
| placeholder | string | The date input placeholder. |
| timezonePlaceholder | string | The timezone input placeholder. |
| style | object or string | The component container's style. Can be a style object or a css string. |
| dateInputStyle | object or string | The date input's style. Can be a style object or a css string. |
| timezoneInputStyle | object | The timezone container's style. Must be a style object. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_DateTimePicker.py)
![](images/datetimepicker.gif)
Keyed File Browser
File and directory browser given a flat keyed list of objects. Implemented with
[React Keyed File Browser](https://github.com/uptick/react-keyed-file-browser).
### Component Properties
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks. |
| selectedPath | string | The current selected path in the file tree. |
| files | array | The file tree to be displayed in the browser. Each entry in the array must be an object with the `key` property, which specifies it's location in the tree. Otherproperties are `modified` and `size`. To be able to receive the path selection feedback, you must enter keys for both files and folders. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_KeyedFileBrowser.py)
![](images/filebrowser.gif)
Tag Input
A tag input component. Implemented with [React Tag Input](https://github.com/leekevinyg/react-tag-input).
### Components Properties
| Argument | Value | Description |
|---|---|---|
| id | string | The ID used to identify this component in Dash callbacks |
| wrapperStyle | object or string | The component wrapper's style. Can be either a style object or a CSS string. |
| tagStyle | object or string | The tag's style. Can be either a style object or a CSS string |
| inputStyle | object or string | The text input's style. Can be either a style object or a CSS string. |
| tagDeleteStyle | object or string | The tag delete button's style. Can be either a style object or a CSS string. |
| placeholder | string | Placeholder for the text input |
| placeholder | string | Placeholder for the text input |
| value | array | The input's current tags array of objects. e.g [{"index": 0, "displayValue": "Tag"}] |
| injectedTags | array | Tags to be inserted on the input. The input's atual tags are replaced. |
[Example File](https://github.com/Tauffer-Consulting/dash-cool-components/blob/master/example_TagInput.py)
![](images/taginput.gif)
%prep
%autosetup -n dash_cool_components-1-0.1.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dash-cool-components -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.8-1
- Package Spec generated