%global _empty_manifest_terminate_build 0
Name: python-text2svg
Version: 0.3.0
Release: 1
Summary: Convert text to SVG file.
License: GPL version 3
URL: https://text2svg.syrusdark.website
Source0: https://mirrors.aliyun.com/pypi/web/packages/29/aa/429cc645cec1be6f245e6dae7009862f73d1316ddab379e619b883eeb0cb/text2svg-0.3.0.tar.gz
%description
Text2SVG
This is a small wrapper aoung Pango and Cairo which allows you to enter a text and get you svg files ready. This is wrapped using Cython.
## Installation
For Windows and MacOS, wheels are provided which seems to be working. For linux it is not recommended to use the `manylinux` wheels which was published to PyPi as it seems that it is working well. Instead you can install Pango and Cairo along with the header files for your package manage and run the below command
```sh
pip install --no-binary :all: text2svg
```
Other users, can directly install using pip,
```sh
pip install text2svg
```
and checking your installation by running the below example.
## Example
This is a small example on how it works.
```py
>>> from text2svg import *
>>> info = TextInfo("Hello World","hello.svg",50,50)
>>> text2svg(info)
```
This will simply create a `hello.svg` in the current working directory.
## Documentation
Documentation is located at https://text2svg.syrusdark.website
## LICENSE
This project along with its documentation is licensed under GPL-v3. See [LICENSE](https://github.com/naveen521kk/text2svg/blob/main/LICENSE) for details.
%package -n python3-text2svg
Summary: Convert text to SVG file.
Provides: python-text2svg
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-text2svg
Text2SVG
This is a small wrapper aoung Pango and Cairo which allows you to enter a text and get you svg files ready. This is wrapped using Cython.
## Installation
For Windows and MacOS, wheels are provided which seems to be working. For linux it is not recommended to use the `manylinux` wheels which was published to PyPi as it seems that it is working well. Instead you can install Pango and Cairo along with the header files for your package manage and run the below command
```sh
pip install --no-binary :all: text2svg
```
Other users, can directly install using pip,
```sh
pip install text2svg
```
and checking your installation by running the below example.
## Example
This is a small example on how it works.
```py
>>> from text2svg import *
>>> info = TextInfo("Hello World","hello.svg",50,50)
>>> text2svg(info)
```
This will simply create a `hello.svg` in the current working directory.
## Documentation
Documentation is located at https://text2svg.syrusdark.website
## LICENSE
This project along with its documentation is licensed under GPL-v3. See [LICENSE](https://github.com/naveen521kk/text2svg/blob/main/LICENSE) for details.
%package help
Summary: Development documents and examples for text2svg
Provides: python3-text2svg-doc
%description help
Text2SVG
This is a small wrapper aoung Pango and Cairo which allows you to enter a text and get you svg files ready. This is wrapped using Cython.
## Installation
For Windows and MacOS, wheels are provided which seems to be working. For linux it is not recommended to use the `manylinux` wheels which was published to PyPi as it seems that it is working well. Instead you can install Pango and Cairo along with the header files for your package manage and run the below command
```sh
pip install --no-binary :all: text2svg
```
Other users, can directly install using pip,
```sh
pip install text2svg
```
and checking your installation by running the below example.
## Example
This is a small example on how it works.
```py
>>> from text2svg import *
>>> info = TextInfo("Hello World","hello.svg",50,50)
>>> text2svg(info)
```
This will simply create a `hello.svg` in the current working directory.
## Documentation
Documentation is located at https://text2svg.syrusdark.website
## LICENSE
This project along with its documentation is licensed under GPL-v3. See [LICENSE](https://github.com/naveen521kk/text2svg/blob/main/LICENSE) for details.
%prep
%autosetup -n text2svg-0.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-text2svg -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.3.0-1
- Package Spec generated