%global _empty_manifest_terminate_build 0 Name: python-alteia Version: 2.7.0 Release: 1 Summary: High-level Python interface to Alteia API License: MIT URL: https://github.com/alteia-ai/alteia-python-sdk Source0: https://mirrors.aliyun.com/pypi/web/packages/cd/b6/e5442c8692c8f1a55c6c5b8d8ea6e1c145a0afcaac0b686962a29c7fee4d/alteia-2.7.0.tar.gz BuildArch: noarch Requires: python3-urllib3 Requires: python3-appdirs Requires: python3-pathvalidate Requires: python3-sphinx Requires: python3-sphinx_autodoc_typehints Requires: python3-sphinx-autobuild Requires: python3-recommonmark Requires: python3-semantic-version Requires: python3-importlib-resources %description

logo

pypi version compatible python versions

> This SDK offers a high-level Python interface to [Alteia APIs](https://www.alteia.com). ## Installation ```bash pip install alteia ``` **requires Python >= 3.6.1, pip >= 20.3* ## Basic usage ```python import alteia sdk = alteia.SDK(user="YOUR_EMAIL_ADDRESS", password="YOUR_ALTEIA_PASSWORD") projects = sdk.projects.search() for project in projects: print(project.name) # My awesome project ```

 

## 📕 Documentation - [Reference documentation](https://alteia.readthedocs.io/en/latest/index.html) - [Jupyter notebook tutorials](https://github.com/alteia-ai/tutorials) ## Contributing Package installation: ```bash poetry install ``` (Optional) To install pre-commit hooks (and detect problems before the pipelines): ```bash pip install pre-commit pre-commit install pre-commit run --all-files pre-commit autoupdate # Optional, to update pre-commit versions ``` %package -n python3-alteia Summary: High-level Python interface to Alteia API Provides: python-alteia BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-alteia

logo

pypi version compatible python versions

> This SDK offers a high-level Python interface to [Alteia APIs](https://www.alteia.com). ## Installation ```bash pip install alteia ``` **requires Python >= 3.6.1, pip >= 20.3* ## Basic usage ```python import alteia sdk = alteia.SDK(user="YOUR_EMAIL_ADDRESS", password="YOUR_ALTEIA_PASSWORD") projects = sdk.projects.search() for project in projects: print(project.name) # My awesome project ```

 

## 📕 Documentation - [Reference documentation](https://alteia.readthedocs.io/en/latest/index.html) - [Jupyter notebook tutorials](https://github.com/alteia-ai/tutorials) ## Contributing Package installation: ```bash poetry install ``` (Optional) To install pre-commit hooks (and detect problems before the pipelines): ```bash pip install pre-commit pre-commit install pre-commit run --all-files pre-commit autoupdate # Optional, to update pre-commit versions ``` %package help Summary: Development documents and examples for alteia Provides: python3-alteia-doc %description help

logo

pypi version compatible python versions

> This SDK offers a high-level Python interface to [Alteia APIs](https://www.alteia.com). ## Installation ```bash pip install alteia ``` **requires Python >= 3.6.1, pip >= 20.3* ## Basic usage ```python import alteia sdk = alteia.SDK(user="YOUR_EMAIL_ADDRESS", password="YOUR_ALTEIA_PASSWORD") projects = sdk.projects.search() for project in projects: print(project.name) # My awesome project ```

 

## 📕 Documentation - [Reference documentation](https://alteia.readthedocs.io/en/latest/index.html) - [Jupyter notebook tutorials](https://github.com/alteia-ai/tutorials) ## Contributing Package installation: ```bash poetry install ``` (Optional) To install pre-commit hooks (and detect problems before the pipelines): ```bash pip install pre-commit pre-commit install pre-commit run --all-files pre-commit autoupdate # Optional, to update pre-commit versions ``` %prep %autosetup -n alteia-2.7.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-alteia -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri Jun 09 2023 Python_Bot - 2.7.0-1 - Package Spec generated