%global _empty_manifest_terminate_build 0
Name: python-Flask-Scrypt
Version: 0.1.3.6
Release: 1
Summary: Flask-Scrypt provides convenient wrappers forscrypt password hashing and random salt generation.
License: MIT
URL: http://github.com/grobins2/flask-scrypt
Source0: https://mirrors.aliyun.com/pypi/web/packages/6a/23/1c65e00b9925d233b064232449a661e64478bd088633529942a175072766/Flask-Scrypt-0.1.3.6.tar.gz
BuildArch: noarch
%description
Flask-Scrypt extension provides scrypt password hashing and
random salt generation for Flask.
Links
`````
* `Documentation `_
* `Development version `_
%package -n python3-Flask-Scrypt
Summary: Flask-Scrypt provides convenient wrappers forscrypt password hashing and random salt generation.
Provides: python-Flask-Scrypt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Flask-Scrypt
Flask-Scrypt extension provides scrypt password hashing and
random salt generation for Flask.
Links
`````
* `Documentation `_
* `Development version `_
%package help
Summary: Development documents and examples for Flask-Scrypt
Provides: python3-Flask-Scrypt-doc
%description help
Flask-Scrypt extension provides scrypt password hashing and
random salt generation for Flask.
Links
`````
* `Documentation `_
* `Development version `_
%prep
%autosetup -n Flask-Scrypt-0.1.3.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Flask-Scrypt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.1.3.6-1
- Package Spec generated