.svg)](https://github.com/Muhammad4hmed/Ghalat-Machine-Learning)
[![PyPI version](https://badge.fury.io/py/GML.svg)](https://pypi.org/project/GML)
[![PyPI license](https://img.shields.io/pypi/l/ansicolortags.svg)](https://pypi.org/project/GML/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/ansicolortags.svg)](https://pypi.org/project/GML/)
[![GitHub issues](https://img.shields.io/github/issues/Muhammad4hmed/Ghalat-Machine-Learning)](https://GitHub.com/Muhammad4hmed/Ghalat-Machine-Learning/issues/)
Creators
Muhammad Ahmed
Naman Tuli
Contributors
Rafey Iqbal Rahman
Tired of doing Data Science manually? GML is here for you!
GML is an automatic data science library in python built on top of multiple Python packages. Complete features which we offer are listed as:
Installation:
```python
pip install GML
```
https://pypi.org/project/GML
Features:
Auto Feature Engineering
```python
from GML import FeatureEngineering
fe = FeatureEngineering(Data, 'target', fill_missing_data=True, encode_data=True,
normalize=True, remove_outliers=True,
new_features=True, feateng_steps=2 ) # feateng_steps = 0 for features selection without feature creation
X_new, y, test = fe.get_new_data()
```
Click Here for complete DEMO
Auto EDA (Powered by Sweetviz)
```python
from GML import sweetviz
result1 = sweetviz.compare([train,'train'],[test,'test'],'target')
result2 = sweetviz.analyze([train,'train'])
result.show_html()
result2.show_html()
```
Click Here for complete DEMO
Auto Machine Learning
```python
from GML import AutoML
gml_ml = AutoML()
gml_ml.GMLClassifier(X, y, metric = accuracy_score, folds = 10)
```
Click Here for complete DEMO
Auto Text Cleaning
```python
from GML import AutoNLP
nlp = AutoNLP()
cleanX = X.apply(lambda x: nlp.clean(x))
```
Click Here for complete DEMO
Auto Text Classification using transformers
```python
from GML import AutoNLP
nlp = AutoNLP()
nlp.set_params(cleanX, tokenizer_name='roberta-large-mnli', BATCH_SIZE=4,
model_name='roberta-large-mnli', MAX_LEN=200)
model = nlp.train_model(tokenizedX, y)
```
Click Here for complete DEMO
Auto Image Classification with Augmentation
```python
from GML import Auto_Image_Processing
gml_image_processing = Auto_Image_Processing()
model = gml_image_processing.imgClassificationcsv(img_path = './covid_image_data/train',
train_path = './covid_image_data/Training_set_covid.csv',
model_list = models,
tfms = True, advance_augmentation = True,
epochs=1)
```
Click Here for complete DEMO
Text Augmentation using transformers: GPT-2
```python
from GML import AutoNLP
nlp = AutoNLP()
nlp.augmentation_train('./data.csv')
nlp.set_params(X['Text'])
new_Text = nlp.augmentation_generate(y = y, SENTENCES = 100)
```
Click Here for complete DEMO
More cool features and handling of different data types like audio data etc will be added in future.
Feel free to give suggestions, report bugs and contribute.
%prep
%autosetup -n GML-3.0.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-GML -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 3.0.6-1
- Package Spec generated