%global _empty_manifest_terminate_build 0
Name: python-peekingduck
Version: 1.3.0.post1
Release: 1
Summary: A modular framework built to simplify Computer Vision inference workloads.
License: Apache Software License
URL: https://github.com/aisingapore/PeekingDuck
Source0: https://mirrors.aliyun.com/pypi/web/packages/5e/4f/f879e608ca17b74363367e26fcc04d95ca851e1b220bdad0fe4f78645954/peekingduck-1.3.0.post1.tar.gz
BuildArch: noarch
Requires: python3-pyyaml
Requires: python3-click
Requires: python3-requests
Requires: python3-opencv-contrib-python
Requires: python3-protobuf
Requires: python3-tensorflow
Requires: python3-numpy
Requires: python3-tqdm
Requires: python3-colorama
Requires: python3-torch
Requires: python3-torchvision
Requires: python3-typeguard
Requires: python3-scipy
%description
[![Python version](https://img.shields.io/badge/python-3.6%20%7C%203.7%20%7C%203.8%20%7C%203.9-blue.svg)](https://pypi.org/project/peekingduck/)
[![PyPI version](https://badge.fury.io/py/peekingduck.svg)](https://pypi.org/project/peekingduck/)
[![PyPI Downloads](https://img.shields.io/pypi/dm/peekingduck)](https://pypi.org/project/peekingduck/)
[![License](https://img.shields.io/badge/license-Apache%202.0-blue.svg)](https://github.com/aisingapore/PeekingDuck/blob/main/LICENSE)
[![Documentation Status](https://readthedocs.org/projects/peekingduck/badge/?version=stable)](https://peekingduck.readthedocs.io/en/stable/?badge=stable)
Getting started
·
Tutorials
·
API docs
·
FAQ
·
Report a bug
·
Communities
%package -n python3-peekingduck
Summary: A modular framework built to simplify Computer Vision inference workloads.
Provides: python-peekingduck
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-peekingduck
[![Python version](https://img.shields.io/badge/python-3.6%20%7C%203.7%20%7C%203.8%20%7C%203.9-blue.svg)](https://pypi.org/project/peekingduck/)
[![PyPI version](https://badge.fury.io/py/peekingduck.svg)](https://pypi.org/project/peekingduck/)
[![PyPI Downloads](https://img.shields.io/pypi/dm/peekingduck)](https://pypi.org/project/peekingduck/)
[![License](https://img.shields.io/badge/license-Apache%202.0-blue.svg)](https://github.com/aisingapore/PeekingDuck/blob/main/LICENSE)
[![Documentation Status](https://readthedocs.org/projects/peekingduck/badge/?version=stable)](https://peekingduck.readthedocs.io/en/stable/?badge=stable)
Getting started
·
Tutorials
·
API docs
·
FAQ
·
Report a bug
·
Communities
%package help
Summary: Development documents and examples for peekingduck
Provides: python3-peekingduck-doc
%description help
[![Python version](https://img.shields.io/badge/python-3.6%20%7C%203.7%20%7C%203.8%20%7C%203.9-blue.svg)](https://pypi.org/project/peekingduck/)
[![PyPI version](https://badge.fury.io/py/peekingduck.svg)](https://pypi.org/project/peekingduck/)
[![PyPI Downloads](https://img.shields.io/pypi/dm/peekingduck)](https://pypi.org/project/peekingduck/)
[![License](https://img.shields.io/badge/license-Apache%202.0-blue.svg)](https://github.com/aisingapore/PeekingDuck/blob/main/LICENSE)
[![Documentation Status](https://readthedocs.org/projects/peekingduck/badge/?version=stable)](https://peekingduck.readthedocs.io/en/stable/?badge=stable)
Getting started
·
Tutorials
·
API docs
·
FAQ
·
Report a bug
·
Communities
%prep
%autosetup -n peekingduck-1.3.0.post1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-peekingduck -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.3.0.post1-1
- Package Spec generated