%global _empty_manifest_terminate_build 0 Name: python-pyheatintegration Version: 0.6.1 Release: 1 Summary: Heat Integration License: MIT URL: https://github.com/tarao1006/pyheatintegration Source0: https://mirrors.aliyun.com/pypi/web/packages/f6/96/978424062aca31c2c0ab6f1472d6656a70f0cdefc7fc4cab408af6c623b7/pyheatintegration-0.6.1.tar.gz BuildArch: noarch %description # pyheatintegration [![Test](https://github.com/tarao1006/pyheatintegration/actions/workflows/test.yml/badge.svg)](https://github.com/tarao1006/pyheatintegration/actions/workflows/test.yml) [![PyPI version](https://badge.fury.io/py/pyheatintegration.svg)](https://badge.fury.io/py/pyheatintegration) ヒートインテグレーションを支援します。グランドコンポジットカーブ、TQ線図の作成に対応しています。
グランドコンポジットカーブ
TQ線図
TQ線図(流体ごとに分割)
TQ線図(流体ごとに分割。最小接近温度差を満たす。)
TQ線図(結合可能な熱交換器を結合。)
## Requirements - Python >= 3.9 ## Installation ``` sh pip install pyheatintegration ``` ## Examples - [simple example](https://github.com/tarao1006/pyheatintegration/tree/main/examples/simple) ## Documentation https://pyheatintegration.readthedocs.io/ja/latest/ ## License MIT %package -n python3-pyheatintegration Summary: Heat Integration Provides: python-pyheatintegration BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-pyheatintegration # pyheatintegration [![Test](https://github.com/tarao1006/pyheatintegration/actions/workflows/test.yml/badge.svg)](https://github.com/tarao1006/pyheatintegration/actions/workflows/test.yml) [![PyPI version](https://badge.fury.io/py/pyheatintegration.svg)](https://badge.fury.io/py/pyheatintegration) ヒートインテグレーションを支援します。グランドコンポジットカーブ、TQ線図の作成に対応しています。
グランドコンポジットカーブ
TQ線図
TQ線図(流体ごとに分割)
TQ線図(流体ごとに分割。最小接近温度差を満たす。)
TQ線図(結合可能な熱交換器を結合。)
## Requirements - Python >= 3.9 ## Installation ``` sh pip install pyheatintegration ``` ## Examples - [simple example](https://github.com/tarao1006/pyheatintegration/tree/main/examples/simple) ## Documentation https://pyheatintegration.readthedocs.io/ja/latest/ ## License MIT %package help Summary: Development documents and examples for pyheatintegration Provides: python3-pyheatintegration-doc %description help # pyheatintegration [![Test](https://github.com/tarao1006/pyheatintegration/actions/workflows/test.yml/badge.svg)](https://github.com/tarao1006/pyheatintegration/actions/workflows/test.yml) [![PyPI version](https://badge.fury.io/py/pyheatintegration.svg)](https://badge.fury.io/py/pyheatintegration) ヒートインテグレーションを支援します。グランドコンポジットカーブ、TQ線図の作成に対応しています。
グランドコンポジットカーブ
TQ線図
TQ線図(流体ごとに分割)
TQ線図(流体ごとに分割。最小接近温度差を満たす。)
TQ線図(結合可能な熱交換器を結合。)
## Requirements - Python >= 3.9 ## Installation ``` sh pip install pyheatintegration ``` ## Examples - [simple example](https://github.com/tarao1006/pyheatintegration/tree/main/examples/simple) ## Documentation https://pyheatintegration.readthedocs.io/ja/latest/ ## License MIT %prep %autosetup -n pyheatintegration-0.6.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-pyheatintegration -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri Jun 09 2023 Python_Bot - 0.6.1-1 - Package Spec generated