%global _empty_manifest_terminate_build 0
Name: python-input-num
Version: 1.1.5
Release: 1
Summary: Python package - input_num is like input but it only accepts numbers
License: MIT
URL: https://github.com/HexagonCore/input_num
Source0: https://mirrors.aliyun.com/pypi/web/packages/f5/1c/1011d796e966898052795f7de52d664398fda6a0b8a732ce520f5164508a/input_num-1.1.5.tar.gz
BuildArch: noarch
Requires: python3-markdown
Requires: python3-requests
%description
[](#/)
[
](#/)
[
](#/)
[
](#/)
[
](#/)
# input_num
Python package - **input_num** is like input but it **only accepts numbers**
___
###
## Installation
* ### Windows / macOS
Run `python3 -m pip install input_num`
* ### Linux
Run `python3 -m pip install input_num`
###
## Usage
* ### Windows / macOS / Linux
Add this to your script: `import input_num` `input_num("Enter your age: ")`
Command scheme: `input_num("Question: ", AllowNegativeNumbers, DoesPressingEnterReturnNothing)`
* First option:
If you want to allow only positive numbers (numbers WITHOUT **-** at the begining), use `input_num("Something", False)`.
*False* just means **Allow negative numbers = False**
And it is **optional argument**
Default value is **True**
* Second option:
There is also second option, does pressing enter return "" ? Set it to **False** to make pressing enter **ask you again**.
Example: `input_num("Try pressing enter: ", True, False)` - this allows negative numbers and disallows entering nothing.
It is **optional argument**
Default value is **True**
⚠️ **If you want to set only second option, set the first option too** ⚠️
Do you want to be reminded to update the package?
Run `input_num.allow_update()` RIGHT AFTER importing the package.
###
## Uninstallation
* ### Windows / macOS
Run `python3 -m pip uninstall input_num`
* ### Linux
Run `python3 -m pip uninstall input_num`
###
## FAQ
* ### Question
Answer
###
Do you like this? Hit that ⭐!
Use the star button as way to show us, that it works
Forks and pull requests are welcome of course
%package -n python3-input-num
Summary: Python package - input_num is like input but it only accepts numbers
Provides: python-input-num
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-input-num
[](#/)
[
](#/)
[
](#/)
[
](#/)
[
](#/)
# input_num
Python package - **input_num** is like input but it **only accepts numbers**
___
###
## Installation
* ### Windows / macOS
Run `python3 -m pip install input_num`
* ### Linux
Run `python3 -m pip install input_num`
###
## Usage
* ### Windows / macOS / Linux
Add this to your script: `import input_num` `input_num("Enter your age: ")`
Command scheme: `input_num("Question: ", AllowNegativeNumbers, DoesPressingEnterReturnNothing)`
* First option:
If you want to allow only positive numbers (numbers WITHOUT **-** at the begining), use `input_num("Something", False)`.
*False* just means **Allow negative numbers = False**
And it is **optional argument**
Default value is **True**
* Second option:
There is also second option, does pressing enter return "" ? Set it to **False** to make pressing enter **ask you again**.
Example: `input_num("Try pressing enter: ", True, False)` - this allows negative numbers and disallows entering nothing.
It is **optional argument**
Default value is **True**
⚠️ **If you want to set only second option, set the first option too** ⚠️
Do you want to be reminded to update the package?
Run `input_num.allow_update()` RIGHT AFTER importing the package.
###
## Uninstallation
* ### Windows / macOS
Run `python3 -m pip uninstall input_num`
* ### Linux
Run `python3 -m pip uninstall input_num`
###
## FAQ
* ### Question
Answer
###
Do you like this? Hit that ⭐!
Use the star button as way to show us, that it works
Forks and pull requests are welcome of course
%package help
Summary: Development documents and examples for input-num
Provides: python3-input-num-doc
%description help
[](#/)
[
](#/)
[
](#/)
[
](#/)
[
](#/)
# input_num
Python package - **input_num** is like input but it **only accepts numbers**
___
###
## Installation
* ### Windows / macOS
Run `python3 -m pip install input_num`
* ### Linux
Run `python3 -m pip install input_num`
###
## Usage
* ### Windows / macOS / Linux
Add this to your script: `import input_num` `input_num("Enter your age: ")`
Command scheme: `input_num("Question: ", AllowNegativeNumbers, DoesPressingEnterReturnNothing)`
* First option:
If you want to allow only positive numbers (numbers WITHOUT **-** at the begining), use `input_num("Something", False)`.
*False* just means **Allow negative numbers = False**
And it is **optional argument**
Default value is **True**
* Second option:
There is also second option, does pressing enter return "" ? Set it to **False** to make pressing enter **ask you again**.
Example: `input_num("Try pressing enter: ", True, False)` - this allows negative numbers and disallows entering nothing.
It is **optional argument**
Default value is **True**
⚠️ **If you want to set only second option, set the first option too** ⚠️
Do you want to be reminded to update the package?
Run `input_num.allow_update()` RIGHT AFTER importing the package.
###
## Uninstallation
* ### Windows / macOS
Run `python3 -m pip uninstall input_num`
* ### Linux
Run `python3 -m pip uninstall input_num`
###
## FAQ
* ### Question
Answer
###
Do you like this? Hit that ⭐!
Use the star button as way to show us, that it works
Forks and pull requests are welcome of course
%prep
%autosetup -n input_num-1.1.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-input-num -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.1.5-1
- Package Spec generated