%global _empty_manifest_terminate_build 0
Name: python-scapy-ssl_tls
Version: 2.0.0
Release: 1
Summary: An SSL/TLS layer for scapy the interactive packet manipulation tool
License: GPLv2
URL: https://github.com/tintinweb/scapy-ssl_tls/
Source0: https://mirrors.aliyun.com/pypi/web/packages/5e/00/2b1455c5b372e1c99c9a76f593afd4e8c4cc35cceec7770f978f36a65c74/scapy-ssl_tls-2.0.0.tar.gz
BuildArch: noarch
%description
SSL/TLS and DTLS layers and TLS utiltiy functions for
`Scapy `_.
An offensive stack for SSLv2, SSLv3 (TLS), TLS, DTLS penetration testing
providing easy access to packet crafting, automatic dissection,
encryption, decryption, session tracking, basic TLS state machines,
automated handshakes, TLSSocket abstraction, cryptography containers,
predefined hooks, SSL sniffing including minimalistic PCAP stream
decryption (RSA\_WITH\_\*), fuzzing and security scanning
(*Renegotiation, Heartbleed, Poodle, Logjam/Freak, DROWN, various Buffer
overflows, ...*).
%package -n python3-scapy-ssl_tls
Summary: An SSL/TLS layer for scapy the interactive packet manipulation tool
Provides: python-scapy-ssl_tls
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-scapy-ssl_tls
SSL/TLS and DTLS layers and TLS utiltiy functions for
`Scapy `_.
An offensive stack for SSLv2, SSLv3 (TLS), TLS, DTLS penetration testing
providing easy access to packet crafting, automatic dissection,
encryption, decryption, session tracking, basic TLS state machines,
automated handshakes, TLSSocket abstraction, cryptography containers,
predefined hooks, SSL sniffing including minimalistic PCAP stream
decryption (RSA\_WITH\_\*), fuzzing and security scanning
(*Renegotiation, Heartbleed, Poodle, Logjam/Freak, DROWN, various Buffer
overflows, ...*).
%package help
Summary: Development documents and examples for scapy-ssl_tls
Provides: python3-scapy-ssl_tls-doc
%description help
SSL/TLS and DTLS layers and TLS utiltiy functions for
`Scapy `_.
An offensive stack for SSLv2, SSLv3 (TLS), TLS, DTLS penetration testing
providing easy access to packet crafting, automatic dissection,
encryption, decryption, session tracking, basic TLS state machines,
automated handshakes, TLSSocket abstraction, cryptography containers,
predefined hooks, SSL sniffing including minimalistic PCAP stream
decryption (RSA\_WITH\_\*), fuzzing and security scanning
(*Renegotiation, Heartbleed, Poodle, Logjam/Freak, DROWN, various Buffer
overflows, ...*).
%prep
%autosetup -n scapy-ssl_tls-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-scapy-ssl_tls -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 2.0.0-1
- Package Spec generated