%global _empty_manifest_terminate_build 0
Name: python-pycpd
Version: 2.0.0
Release: 1
Summary: Pure Numpy Implementation of the Coherent Point Drift Algorithm
License: MIT
URL: https://github.com/siavashk/pycpd
Source0: https://mirrors.aliyun.com/pypi/web/packages/c7/e3/e867299fbc745cbec071c13d45b74e255e86752da9ebd8962bf55fc54aa4/pycpd-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-future
%description
#############
Python-CPD
#############
.. image:: https://travis-ci.com/siavashk/pycpd.svg?branch=master
:target: https://travis-ci.com/siavashk/pycpd
Pure Numpy Implementation of the Coherent Point Drift Algorithm.
MIT License.
*************
Introduction
*************
This is a pure numpy implementation of the coherent point drift `CPD `_ algorithm by Myronenko and Song. It provides three registration methods for point clouds: 1) Scale and rigid registration; 2) Affine registration; and 3) Gaussian regularized non-rigid registration.
The CPD algorithm is a registration method for aligning two point clouds. In this method, the moving point cloud is modelled as a Gaussian Mixture Model (GMM) and the fixed point cloud are treated as observations from the GMM. The optimal transformation parameters maximze the Maximum A Posteriori (MAP) estimation that the observed point cloud is drawn from the GMM.
The registration methods work for 2D and 3D point clouds. For more information, please refer to my `blog `_.
*************
Pip Install
*************
.. code-block:: bash
pip install pycpd
************************
Installation From Source
************************
Clone the repository to a location, referred to as the ``root`` folder. For example:
.. code-block:: bash
git clone https://github.com/siavashk/pycpd.git $HOME/pycpd
Install the package:
.. code-block:: bash
pip install .
For running sample registration examples under ``examples``, you will need ``matplotlib`` to visualize the registration. This can be downloaded by running:
.. code-block:: bash
pip install matplotlib
*****
Usage
*****
Each registration method is contained within a single class inside the ``pycpd`` subfolder. To try out the registration, you can simply run:
.. code-block:: bash
python examples/fish_{Transform}_{Dimension}.py
where ``Transform`` is either ``rigid``, ``affine`` or ``deformable`` and ``Dimension`` is either ``2D`` or ``3D``. Note that examples are meant to be run from the ``root`` folder.
%package -n python3-pycpd
Summary: Pure Numpy Implementation of the Coherent Point Drift Algorithm
Provides: python-pycpd
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pycpd
#############
Python-CPD
#############
.. image:: https://travis-ci.com/siavashk/pycpd.svg?branch=master
:target: https://travis-ci.com/siavashk/pycpd
Pure Numpy Implementation of the Coherent Point Drift Algorithm.
MIT License.
*************
Introduction
*************
This is a pure numpy implementation of the coherent point drift `CPD `_ algorithm by Myronenko and Song. It provides three registration methods for point clouds: 1) Scale and rigid registration; 2) Affine registration; and 3) Gaussian regularized non-rigid registration.
The CPD algorithm is a registration method for aligning two point clouds. In this method, the moving point cloud is modelled as a Gaussian Mixture Model (GMM) and the fixed point cloud are treated as observations from the GMM. The optimal transformation parameters maximze the Maximum A Posteriori (MAP) estimation that the observed point cloud is drawn from the GMM.
The registration methods work for 2D and 3D point clouds. For more information, please refer to my `blog `_.
*************
Pip Install
*************
.. code-block:: bash
pip install pycpd
************************
Installation From Source
************************
Clone the repository to a location, referred to as the ``root`` folder. For example:
.. code-block:: bash
git clone https://github.com/siavashk/pycpd.git $HOME/pycpd
Install the package:
.. code-block:: bash
pip install .
For running sample registration examples under ``examples``, you will need ``matplotlib`` to visualize the registration. This can be downloaded by running:
.. code-block:: bash
pip install matplotlib
*****
Usage
*****
Each registration method is contained within a single class inside the ``pycpd`` subfolder. To try out the registration, you can simply run:
.. code-block:: bash
python examples/fish_{Transform}_{Dimension}.py
where ``Transform`` is either ``rigid``, ``affine`` or ``deformable`` and ``Dimension`` is either ``2D`` or ``3D``. Note that examples are meant to be run from the ``root`` folder.
%package help
Summary: Development documents and examples for pycpd
Provides: python3-pycpd-doc
%description help
#############
Python-CPD
#############
.. image:: https://travis-ci.com/siavashk/pycpd.svg?branch=master
:target: https://travis-ci.com/siavashk/pycpd
Pure Numpy Implementation of the Coherent Point Drift Algorithm.
MIT License.
*************
Introduction
*************
This is a pure numpy implementation of the coherent point drift `CPD `_ algorithm by Myronenko and Song. It provides three registration methods for point clouds: 1) Scale and rigid registration; 2) Affine registration; and 3) Gaussian regularized non-rigid registration.
The CPD algorithm is a registration method for aligning two point clouds. In this method, the moving point cloud is modelled as a Gaussian Mixture Model (GMM) and the fixed point cloud are treated as observations from the GMM. The optimal transformation parameters maximze the Maximum A Posteriori (MAP) estimation that the observed point cloud is drawn from the GMM.
The registration methods work for 2D and 3D point clouds. For more information, please refer to my `blog `_.
*************
Pip Install
*************
.. code-block:: bash
pip install pycpd
************************
Installation From Source
************************
Clone the repository to a location, referred to as the ``root`` folder. For example:
.. code-block:: bash
git clone https://github.com/siavashk/pycpd.git $HOME/pycpd
Install the package:
.. code-block:: bash
pip install .
For running sample registration examples under ``examples``, you will need ``matplotlib`` to visualize the registration. This can be downloaded by running:
.. code-block:: bash
pip install matplotlib
*****
Usage
*****
Each registration method is contained within a single class inside the ``pycpd`` subfolder. To try out the registration, you can simply run:
.. code-block:: bash
python examples/fish_{Transform}_{Dimension}.py
where ``Transform`` is either ``rigid``, ``affine`` or ``deformable`` and ``Dimension`` is either ``2D`` or ``3D``. Note that examples are meant to be run from the ``root`` folder.
%prep
%autosetup -n pycpd-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pycpd -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 2.0.0-1
- Package Spec generated