%global _empty_manifest_terminate_build 0 Name: python-imagescore Version: 1.1.0 Release: 1 Summary: Calculates the similarity score between images License: MIT URL: https://github.com/sandjaie/image_score Source0: https://mirrors.aliyun.com/pypi/web/packages/ae/45/fbf98301e5d2b2fb004e13decda0c0456751a06402d03684c74351f309c9/imagescore-1.1.0.tar.gz BuildArch: noarch %description ## Bjorn score [![Build Status](https://travis-ci.com/sandjaie/image_score.svg?branch=master)](https://travis-ci.com/sandjaie/image_score) ![PyPI](https://img.shields.io/pypi/v/imagescore.svg) ![PyPI - Python Version](https://img.shields.io/pypi/pyversions/imagescore.svg) ### Calculate image similarity score #### Tools used: ``` Language: Python Dev Modules Used: - opencv-python - scikit-image - click Test Modules Used: - tox - pytest - pylint - pytest-cov Build and Deployment: Travis-ci App Repository: PyPi ``` #### Installation:
`pip3 install imagescore` #### How to run:
`imagescore --infile 'input.csv' --outfile 'output.csv'` #### The options are:
--infile | -i [str] -- [Input file path] --outfile | -o [str] -- [Output file path] --height | -h [int] -- [Optional: height to be resized, default = 4096] --width | -w [int] -- [Optional: width to be resized, default = 4096] Expected Input: csv file with images and its absolute path
Expected Output: csv file with images and its absolute path, image score and elapsed time in secs.
#### Developer mode:
The application is written in python3. Hence create a virtualenv with python3 and install the dependencies from `requirements.txt`. ``` virtualenv --python=python3 venv pip install -e . ``` The unit test cases are located in tests directory. Install the dependencies `requrements-dev.txt`. ``` pip install -r requirements-dev.txt tox ``` #### Deployment:
The python package is build with the travis.yml script when there are changes on the master branch. To push a new version: Make the changes in the application, push it to any feature branch and merge with master.
To deploy a new version tag it. e.g ``` git tag -a v1.1.0 git push origin v1.1.0 ``` When a tag is pushed, travis starts building and uploads the application to pypi
Pypi Release: https://pypi.org/project/imagescore/
Github Release: https://github.com/sandjaie/image_score/releases
Travis Builds: https://travis-ci.com/sandjaie/image_score/
Manual Deployment:
We are using twine to upload the artifact to Pypi registry. Pypi registry needs an account to be created. Enter the credentials in the cli when prompted. ``` pip3 install twine python3 setup.py sdist bdist_wheel twine upload dist/* ``` %package -n python3-imagescore Summary: Calculates the similarity score between images Provides: python-imagescore BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-imagescore ## Bjorn score [![Build Status](https://travis-ci.com/sandjaie/image_score.svg?branch=master)](https://travis-ci.com/sandjaie/image_score) ![PyPI](https://img.shields.io/pypi/v/imagescore.svg) ![PyPI - Python Version](https://img.shields.io/pypi/pyversions/imagescore.svg) ### Calculate image similarity score #### Tools used: ``` Language: Python Dev Modules Used: - opencv-python - scikit-image - click Test Modules Used: - tox - pytest - pylint - pytest-cov Build and Deployment: Travis-ci App Repository: PyPi ``` #### Installation:
`pip3 install imagescore` #### How to run:
`imagescore --infile 'input.csv' --outfile 'output.csv'` #### The options are:
--infile | -i [str] -- [Input file path] --outfile | -o [str] -- [Output file path] --height | -h [int] -- [Optional: height to be resized, default = 4096] --width | -w [int] -- [Optional: width to be resized, default = 4096] Expected Input: csv file with images and its absolute path
Expected Output: csv file with images and its absolute path, image score and elapsed time in secs.
#### Developer mode:
The application is written in python3. Hence create a virtualenv with python3 and install the dependencies from `requirements.txt`. ``` virtualenv --python=python3 venv pip install -e . ``` The unit test cases are located in tests directory. Install the dependencies `requrements-dev.txt`. ``` pip install -r requirements-dev.txt tox ``` #### Deployment:
The python package is build with the travis.yml script when there are changes on the master branch. To push a new version: Make the changes in the application, push it to any feature branch and merge with master.
To deploy a new version tag it. e.g ``` git tag -a v1.1.0 git push origin v1.1.0 ``` When a tag is pushed, travis starts building and uploads the application to pypi
Pypi Release: https://pypi.org/project/imagescore/
Github Release: https://github.com/sandjaie/image_score/releases
Travis Builds: https://travis-ci.com/sandjaie/image_score/
Manual Deployment:
We are using twine to upload the artifact to Pypi registry. Pypi registry needs an account to be created. Enter the credentials in the cli when prompted. ``` pip3 install twine python3 setup.py sdist bdist_wheel twine upload dist/* ``` %package help Summary: Development documents and examples for imagescore Provides: python3-imagescore-doc %description help ## Bjorn score [![Build Status](https://travis-ci.com/sandjaie/image_score.svg?branch=master)](https://travis-ci.com/sandjaie/image_score) ![PyPI](https://img.shields.io/pypi/v/imagescore.svg) ![PyPI - Python Version](https://img.shields.io/pypi/pyversions/imagescore.svg) ### Calculate image similarity score #### Tools used: ``` Language: Python Dev Modules Used: - opencv-python - scikit-image - click Test Modules Used: - tox - pytest - pylint - pytest-cov Build and Deployment: Travis-ci App Repository: PyPi ``` #### Installation:
`pip3 install imagescore` #### How to run:
`imagescore --infile 'input.csv' --outfile 'output.csv'` #### The options are:
--infile | -i [str] -- [Input file path] --outfile | -o [str] -- [Output file path] --height | -h [int] -- [Optional: height to be resized, default = 4096] --width | -w [int] -- [Optional: width to be resized, default = 4096] Expected Input: csv file with images and its absolute path
Expected Output: csv file with images and its absolute path, image score and elapsed time in secs.
#### Developer mode:
The application is written in python3. Hence create a virtualenv with python3 and install the dependencies from `requirements.txt`. ``` virtualenv --python=python3 venv pip install -e . ``` The unit test cases are located in tests directory. Install the dependencies `requrements-dev.txt`. ``` pip install -r requirements-dev.txt tox ``` #### Deployment:
The python package is build with the travis.yml script when there are changes on the master branch. To push a new version: Make the changes in the application, push it to any feature branch and merge with master.
To deploy a new version tag it. e.g ``` git tag -a v1.1.0 git push origin v1.1.0 ``` When a tag is pushed, travis starts building and uploads the application to pypi
Pypi Release: https://pypi.org/project/imagescore/
Github Release: https://github.com/sandjaie/image_score/releases
Travis Builds: https://travis-ci.com/sandjaie/image_score/
Manual Deployment:
We are using twine to upload the artifact to Pypi registry. Pypi registry needs an account to be created. Enter the credentials in the cli when prompted. ``` pip3 install twine python3 setup.py sdist bdist_wheel twine upload dist/* ``` %prep %autosetup -n imagescore-1.1.0 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-imagescore -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 1.1.0-1 - Package Spec generated