%global _empty_manifest_terminate_build 0
Name: python-md5ct
Version: 0.1.8
Release: 1
Summary: a md5 batch change tool
License: MIT License
URL: https://github.com/ixiongyu/md5changer
Source0: https://mirrors.aliyun.com/pypi/web/packages/6b/dd/985445fea2ba913da40923db711837c4d686a6a78a9a91b57e726e0b9a1f/md5ct-0.1.8.tar.gz
BuildArch: noarch
%description
# change the MD5 [![The MIT License](https://img.shields.io/badge/license-MIT-green.svg?style=flat-square)](http://opensource.org/licenses/MIT) [![PyPI](https://img.shields.io/pypi/v/md5ct.svg?style=flat-square)](https://pypi.org/project/md5ct/)
可以批量修改文件或者文件夹下文件的md5
文件名转换为拼音
## 安装
``` shell
$ pip3 install md5ct
```
## 使用
``` shell
$ ctmd5 -[你的路径] -py(可选,是否将文件名转为拼音) -rv(可选,是否将文件反转)
```
## LICENSE
The MIT License [@ixiongyu](https://github.com/ixiongyu)
## 感谢 JetBrains 免费的开源授权
## 作者信息
作者博客:https://blog.csdn.net/
作者邮箱: ixiongyu@gmail.com
%package -n python3-md5ct
Summary: a md5 batch change tool
Provides: python-md5ct
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-md5ct
# change the MD5 [![The MIT License](https://img.shields.io/badge/license-MIT-green.svg?style=flat-square)](http://opensource.org/licenses/MIT) [![PyPI](https://img.shields.io/pypi/v/md5ct.svg?style=flat-square)](https://pypi.org/project/md5ct/)
可以批量修改文件或者文件夹下文件的md5
文件名转换为拼音
## 安装
``` shell
$ pip3 install md5ct
```
## 使用
``` shell
$ ctmd5 -[你的路径] -py(可选,是否将文件名转为拼音) -rv(可选,是否将文件反转)
```
## LICENSE
The MIT License [@ixiongyu](https://github.com/ixiongyu)
## 感谢 JetBrains 免费的开源授权
## 作者信息
作者博客:https://blog.csdn.net/
作者邮箱: ixiongyu@gmail.com
%package help
Summary: Development documents and examples for md5ct
Provides: python3-md5ct-doc
%description help
# change the MD5 [![The MIT License](https://img.shields.io/badge/license-MIT-green.svg?style=flat-square)](http://opensource.org/licenses/MIT) [![PyPI](https://img.shields.io/pypi/v/md5ct.svg?style=flat-square)](https://pypi.org/project/md5ct/)
可以批量修改文件或者文件夹下文件的md5
文件名转换为拼音
## 安装
``` shell
$ pip3 install md5ct
```
## 使用
``` shell
$ ctmd5 -[你的路径] -py(可选,是否将文件名转为拼音) -rv(可选,是否将文件反转)
```
## LICENSE
The MIT License [@ixiongyu](https://github.com/ixiongyu)
## 感谢 JetBrains 免费的开源授权
## 作者信息
作者博客:https://blog.csdn.net/
作者邮箱: ixiongyu@gmail.com
%prep
%autosetup -n md5ct-0.1.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-md5ct -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.8-1
- Package Spec generated