%global _empty_manifest_terminate_build 0
Name: python-sendbee-api
Version: 1.7.0
Release: 1
Summary: Python client SDK for Sendbee Public API
License: MIT
URL: https://github.com/sendbee/sendbee-python-client
Source0: https://mirrors.aliyun.com/pypi/web/packages/8a/bb/3f84e945e0c8a886bb240f7466db4027b7f47bb6537e92e35593d3e69ddd/sendbee_api-1.7.0.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-requests
Requires: python3-dumpit
Requires: python3-aenum
Requires: python3-ujson
Requires: python3-cryptography
%description
image | Message template can be sent with image URL: JPG/JPEG, PNG
video | Message template can be sent with video URL: MP4, 3GPP
document | Message template can be sent with document URL: PDF, DOC, DOCX, PPT, PPTX, XLS, XLSX
null | Message template does not support attachment URL
```python
response = api.send_template_message(
phone='+...',
template_keyword='...',
# every pre-created and approved message template
# is identified with a keyword
language='...',
# language keyword
# example: en (for english)
tags={'__tag_key__': '__tag_value__', ...},
# tags for template messages are parts of the message that need
# to be filled with your custom data
# example:
# template message: "Welcome {{1}}! How can we help you?"
# tags: {"1": "John"}
# Learn more: https://developer.sendbee.io/#send-message-template
button_tags={'__tag_key__': '__tag_value__', ...}
# tags for call-to-action button with dynamic URL suffix that need
# to be filled with your custom data
# example:
# template message: https://example.com/{{1}}
# tags: {"1": "page/123"}
[prevent_bot_off=True|False],
# if set to True, will prevent turning-off chatbot for the conversation
# default system behaviour is that chatbot is turned-off
[attachment='http...']
)
response.status
response.conversation_id
response.message_id
# save this id, and when you get sent message status requests on
# your webhook, you'll get this same id to identify the conversation
```
### Send message
You can send either text message or media message.
For media message, following formats are supported:
%package -n python3-sendbee-api
Summary: Python client SDK for Sendbee Public API
Provides: python-sendbee-api
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sendbee-api
image | Message template can be sent with image URL: JPG/JPEG, PNG
video | Message template can be sent with video URL: MP4, 3GPP
document | Message template can be sent with document URL: PDF, DOC, DOCX, PPT, PPTX, XLS, XLSX
null | Message template does not support attachment URL
```python
response = api.send_template_message(
phone='+...',
template_keyword='...',
# every pre-created and approved message template
# is identified with a keyword
language='...',
# language keyword
# example: en (for english)
tags={'__tag_key__': '__tag_value__', ...},
# tags for template messages are parts of the message that need
# to be filled with your custom data
# example:
# template message: "Welcome {{1}}! How can we help you?"
# tags: {"1": "John"}
# Learn more: https://developer.sendbee.io/#send-message-template
button_tags={'__tag_key__': '__tag_value__', ...}
# tags for call-to-action button with dynamic URL suffix that need
# to be filled with your custom data
# example:
# template message: https://example.com/{{1}}
# tags: {"1": "page/123"}
[prevent_bot_off=True|False],
# if set to True, will prevent turning-off chatbot for the conversation
# default system behaviour is that chatbot is turned-off
[attachment='http...']
)
response.status
response.conversation_id
response.message_id
# save this id, and when you get sent message status requests on
# your webhook, you'll get this same id to identify the conversation
```
### Send message
You can send either text message or media message.
For media message, following formats are supported:
%package help
Summary: Development documents and examples for sendbee-api
Provides: python3-sendbee-api-doc
%description help
image | Message template can be sent with image URL: JPG/JPEG, PNG
video | Message template can be sent with video URL: MP4, 3GPP
document | Message template can be sent with document URL: PDF, DOC, DOCX, PPT, PPTX, XLS, XLSX
null | Message template does not support attachment URL
```python
response = api.send_template_message(
phone='+...',
template_keyword='...',
# every pre-created and approved message template
# is identified with a keyword
language='...',
# language keyword
# example: en (for english)
tags={'__tag_key__': '__tag_value__', ...},
# tags for template messages are parts of the message that need
# to be filled with your custom data
# example:
# template message: "Welcome {{1}}! How can we help you?"
# tags: {"1": "John"}
# Learn more: https://developer.sendbee.io/#send-message-template
button_tags={'__tag_key__': '__tag_value__', ...}
# tags for call-to-action button with dynamic URL suffix that need
# to be filled with your custom data
# example:
# template message: https://example.com/{{1}}
# tags: {"1": "page/123"}
[prevent_bot_off=True|False],
# if set to True, will prevent turning-off chatbot for the conversation
# default system behaviour is that chatbot is turned-off
[attachment='http...']
)
response.status
response.conversation_id
response.message_id
# save this id, and when you get sent message status requests on
# your webhook, you'll get this same id to identify the conversation
```
### Send message
You can send either text message or media message.
For media message, following formats are supported:
%prep
%autosetup -n sendbee_api-1.7.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sendbee-api -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.7.0-1
- Package Spec generated