%global _empty_manifest_terminate_build 0
Name: python-phiflow
Version: 2.4.0
Release: 1
Summary: Differentiable PDE solving framework for machine learning
License: MIT
URL: https://github.com/tum-pbs/PhiFlow
Source0: https://mirrors.aliyun.com/pypi/web/packages/3f/66/54b9d31001cff546e9bcd80415c4e7ff30cdfad4dd5042e0764e9207ffad/phiflow-2.4.0.tar.gz
BuildArch: noarch
%description
# PhiFlow
[**Homepage**](https://github.com/tum-pbs/PhiFlow)
[**Documentation**](https://tum-pbs.github.io/PhiFlow/)
[**API**](https://tum-pbs.github.io/PhiFlow/phi)
[**Demos**](https://github.com/tum-pbs/PhiFlow/tree/master/demos)
[
**Fluids Tutorial**](https://colab.research.google.com/github/tum-pbs/PhiFlow/blob/develop/docs/Fluids_Tutorial.ipynb#offline=true&sandboxMode=true)
[
**Playground**](https://colab.research.google.com/drive/1zBlQbmNguRt-Vt332YvdTqlV4DBcus2S#offline=true&sandboxMode=true)
PhiFlow is an open-source simulation toolkit built for optimization and machine learning applications.
It is written mostly in Python and can be used with NumPy, TensorFlow, Jax or PyTorch.
The close integration with machine learning frameworks allows it to leverage their automatic differentiation functionality,
making it easy to build end-to-end differentiable functions involving both learning models and physics simulations.
See the [installation Instructions](https://tum-pbs.github.io/PhiFlow/Installation_Instructions.html) on how to compile the optional custom CUDA operations.
%package -n python3-phiflow
Summary: Differentiable PDE solving framework for machine learning
Provides: python-phiflow
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-phiflow
# PhiFlow
[**Homepage**](https://github.com/tum-pbs/PhiFlow)
[**Documentation**](https://tum-pbs.github.io/PhiFlow/)
[**API**](https://tum-pbs.github.io/PhiFlow/phi)
[**Demos**](https://github.com/tum-pbs/PhiFlow/tree/master/demos)
[
**Fluids Tutorial**](https://colab.research.google.com/github/tum-pbs/PhiFlow/blob/develop/docs/Fluids_Tutorial.ipynb#offline=true&sandboxMode=true)
[
**Playground**](https://colab.research.google.com/drive/1zBlQbmNguRt-Vt332YvdTqlV4DBcus2S#offline=true&sandboxMode=true)
PhiFlow is an open-source simulation toolkit built for optimization and machine learning applications.
It is written mostly in Python and can be used with NumPy, TensorFlow, Jax or PyTorch.
The close integration with machine learning frameworks allows it to leverage their automatic differentiation functionality,
making it easy to build end-to-end differentiable functions involving both learning models and physics simulations.
See the [installation Instructions](https://tum-pbs.github.io/PhiFlow/Installation_Instructions.html) on how to compile the optional custom CUDA operations.
%package help
Summary: Development documents and examples for phiflow
Provides: python3-phiflow-doc
%description help
# PhiFlow
[**Homepage**](https://github.com/tum-pbs/PhiFlow)
[**Documentation**](https://tum-pbs.github.io/PhiFlow/)
[**API**](https://tum-pbs.github.io/PhiFlow/phi)
[**Demos**](https://github.com/tum-pbs/PhiFlow/tree/master/demos)
[
**Fluids Tutorial**](https://colab.research.google.com/github/tum-pbs/PhiFlow/blob/develop/docs/Fluids_Tutorial.ipynb#offline=true&sandboxMode=true)
[
**Playground**](https://colab.research.google.com/drive/1zBlQbmNguRt-Vt332YvdTqlV4DBcus2S#offline=true&sandboxMode=true)
PhiFlow is an open-source simulation toolkit built for optimization and machine learning applications.
It is written mostly in Python and can be used with NumPy, TensorFlow, Jax or PyTorch.
The close integration with machine learning frameworks allows it to leverage their automatic differentiation functionality,
making it easy to build end-to-end differentiable functions involving both learning models and physics simulations.
See the [installation Instructions](https://tum-pbs.github.io/PhiFlow/Installation_Instructions.html) on how to compile the optional custom CUDA operations.
%prep
%autosetup -n phiflow-2.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-phiflow -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 2.4.0-1
- Package Spec generated