%global _empty_manifest_terminate_build 0
Name: python-tembo
Version: 0.0.8
Release: 1
Summary: A simple folder organiser for your work notes.
License: MIT
URL: https://tembo-pages.github.io/tembo-core/
Source0: https://mirrors.aliyun.com/pypi/web/packages/f1/f2/bf4692efa228d1919f1034a3c830def33c37bfa3b216e4ccb99f19ccc3ee/tembo-0.0.8.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-pendulum
Requires: python3-Jinja2
Requires: python3-panaetius
%description
# Tembo
A simple folder organiser for your work notes.
%package -n python3-tembo
Summary: A simple folder organiser for your work notes.
Provides: python-tembo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-tembo
# Tembo
A simple folder organiser for your work notes.
%package help
Summary: Development documents and examples for tembo
Provides: python3-tembo-doc
%description help
# Tembo
A simple folder organiser for your work notes.
%prep
%autosetup -n tembo-0.0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-tembo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.0.8-1
- Package Spec generated