%global _empty_manifest_terminate_build 0
Name: python-labext
Version: 4.1.6
Release: 1
Summary: Extra widgets for Jupyter Lab
License: MIT
URL: https://github.com/binh-vu/labext
Source0: https://mirrors.aliyun.com/pypi/web/packages/3c/f3/830b25b264fefc19354f850fe346a77f17b58014c8b1eb8fb7f4ad357f3f/labext-4.1.6.tar.gz
BuildArch: noarch
%description
labext
![PyPI](https://img.shields.io/pypi/v/labext)
![Python](https://img.shields.io/badge/python-v3.6+-blue.svg)
[![GitHub Issues](https://img.shields.io/github/issues/binh-vu/labext.svg)](https://github.com/binh-vu/labext/issues)
![Contributions welcome](https://img.shields.io/badge/contributions-welcome-orange.svg)
[![License](https://img.shields.io/badge/license-MIT-blue.svg)](https://opensource.org/licenses/MIT)
## Overview
This library provides pre-built widgets and integrates some additional JS libraries to provide an even better experience to work with data in Jupyter Lab.
Features:
1. Better display for pandas data frame.
2. Pop-over content, allowing to show additional content when hovering over a DOM element.
3. Widgets for interactive labeling/annotating data in Jupyter Lab.
## Usage
See the [Demo](./demo.ipynb) notebook for how to use the library. Demo:
1. Converting DataFrame to DataTable
![DataTable](./assets/datatable.gif)
2. Pop-over (Tippy)
![Tippy](./assets/tippy.gif)
3. Slider
![Slider](./assets/slider.gif)
4. Annotator
![Annotator](./assets/annotator.gif)
## Installation
### Docker
I provide a [Dockerfile](./Dockerfile) that create a base environment to run this library. To run the [demo](./demo.ipynb) notebook in docker, you can use [docker-compose](./docker-compose.yml) to start a jupyter lab:
```bash
docker-compose up
```
### Manual
To use this with JupyterLab, you need to have `requirejs` enable in Jupyter by installing either:
1. https://github.com/DraTeots/jupyterlab_requirejs (jupyterlab version <= 1.*)
2. https://github.com/binh-vu/jupyterlab_requirejs (jupyterlab version >= 2.*)
Beside `requirejs`, you also need to have `ipywidgets`, `ipyevents`, `ipycallback`
```bash
pip install ipywidgets ipyevents ipycallback
jupyter nbextension enable --py widgetsnbextension
jupyter nbextension enable --py --sys-prefix ipyevents
jupyter labextension install @jupyter-widgets/jupyterlab-manager ipyevents ipycallback
```
Finally, install this package directly from `pypi`:
```bash
pip install -U labext
```
## Development
To compile the typescript files you need to install:
```bash
npm install @types/jquery
```
Then compiles all `.ts` files, remove`--watch` if you don't want to monitor for changes.
```bash
tsc --target es2017 --watch **/*.ts
```
%package -n python3-labext
Summary: Extra widgets for Jupyter Lab
Provides: python-labext
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-labext
labext
![PyPI](https://img.shields.io/pypi/v/labext)
![Python](https://img.shields.io/badge/python-v3.6+-blue.svg)
[![GitHub Issues](https://img.shields.io/github/issues/binh-vu/labext.svg)](https://github.com/binh-vu/labext/issues)
![Contributions welcome](https://img.shields.io/badge/contributions-welcome-orange.svg)
[![License](https://img.shields.io/badge/license-MIT-blue.svg)](https://opensource.org/licenses/MIT)
## Overview
This library provides pre-built widgets and integrates some additional JS libraries to provide an even better experience to work with data in Jupyter Lab.
Features:
1. Better display for pandas data frame.
2. Pop-over content, allowing to show additional content when hovering over a DOM element.
3. Widgets for interactive labeling/annotating data in Jupyter Lab.
## Usage
See the [Demo](./demo.ipynb) notebook for how to use the library. Demo:
1. Converting DataFrame to DataTable
![DataTable](./assets/datatable.gif)
2. Pop-over (Tippy)
![Tippy](./assets/tippy.gif)
3. Slider
![Slider](./assets/slider.gif)
4. Annotator
![Annotator](./assets/annotator.gif)
## Installation
### Docker
I provide a [Dockerfile](./Dockerfile) that create a base environment to run this library. To run the [demo](./demo.ipynb) notebook in docker, you can use [docker-compose](./docker-compose.yml) to start a jupyter lab:
```bash
docker-compose up
```
### Manual
To use this with JupyterLab, you need to have `requirejs` enable in Jupyter by installing either:
1. https://github.com/DraTeots/jupyterlab_requirejs (jupyterlab version <= 1.*)
2. https://github.com/binh-vu/jupyterlab_requirejs (jupyterlab version >= 2.*)
Beside `requirejs`, you also need to have `ipywidgets`, `ipyevents`, `ipycallback`
```bash
pip install ipywidgets ipyevents ipycallback
jupyter nbextension enable --py widgetsnbextension
jupyter nbextension enable --py --sys-prefix ipyevents
jupyter labextension install @jupyter-widgets/jupyterlab-manager ipyevents ipycallback
```
Finally, install this package directly from `pypi`:
```bash
pip install -U labext
```
## Development
To compile the typescript files you need to install:
```bash
npm install @types/jquery
```
Then compiles all `.ts` files, remove`--watch` if you don't want to monitor for changes.
```bash
tsc --target es2017 --watch **/*.ts
```
%package help
Summary: Development documents and examples for labext
Provides: python3-labext-doc
%description help
labext
![PyPI](https://img.shields.io/pypi/v/labext)
![Python](https://img.shields.io/badge/python-v3.6+-blue.svg)
[![GitHub Issues](https://img.shields.io/github/issues/binh-vu/labext.svg)](https://github.com/binh-vu/labext/issues)
![Contributions welcome](https://img.shields.io/badge/contributions-welcome-orange.svg)
[![License](https://img.shields.io/badge/license-MIT-blue.svg)](https://opensource.org/licenses/MIT)
## Overview
This library provides pre-built widgets and integrates some additional JS libraries to provide an even better experience to work with data in Jupyter Lab.
Features:
1. Better display for pandas data frame.
2. Pop-over content, allowing to show additional content when hovering over a DOM element.
3. Widgets for interactive labeling/annotating data in Jupyter Lab.
## Usage
See the [Demo](./demo.ipynb) notebook for how to use the library. Demo:
1. Converting DataFrame to DataTable
![DataTable](./assets/datatable.gif)
2. Pop-over (Tippy)
![Tippy](./assets/tippy.gif)
3. Slider
![Slider](./assets/slider.gif)
4. Annotator
![Annotator](./assets/annotator.gif)
## Installation
### Docker
I provide a [Dockerfile](./Dockerfile) that create a base environment to run this library. To run the [demo](./demo.ipynb) notebook in docker, you can use [docker-compose](./docker-compose.yml) to start a jupyter lab:
```bash
docker-compose up
```
### Manual
To use this with JupyterLab, you need to have `requirejs` enable in Jupyter by installing either:
1. https://github.com/DraTeots/jupyterlab_requirejs (jupyterlab version <= 1.*)
2. https://github.com/binh-vu/jupyterlab_requirejs (jupyterlab version >= 2.*)
Beside `requirejs`, you also need to have `ipywidgets`, `ipyevents`, `ipycallback`
```bash
pip install ipywidgets ipyevents ipycallback
jupyter nbextension enable --py widgetsnbextension
jupyter nbextension enable --py --sys-prefix ipyevents
jupyter labextension install @jupyter-widgets/jupyterlab-manager ipyevents ipycallback
```
Finally, install this package directly from `pypi`:
```bash
pip install -U labext
```
## Development
To compile the typescript files you need to install:
```bash
npm install @types/jquery
```
Then compiles all `.ts` files, remove`--watch` if you don't want to monitor for changes.
```bash
tsc --target es2017 --watch **/*.ts
```
%prep
%autosetup -n labext-4.1.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-labext -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 4.1.6-1
- Package Spec generated