%global _empty_manifest_terminate_build 0
Name: python-speedup-work-lib
Version: 0.3.2
Release: 1
Summary: A Python library to speed up work
License: Apache
URL: https://github.com/mndarren/Speedup-Work-Lib.git
Source0: https://mirrors.aliyun.com/pypi/web/packages/ba/4d/1c6d19c457f007c82b94a318a751d5d4e59452e1baa78720147716ed680c/speedup_work_lib-0.3.2.tar.gz
BuildArch: noarch
Requires: python3-paramiko
%description
# Speedup-Work-Lib
This repo is a library for speed up work
## Get Started
> There are **3 COMPONENTS** in Speedup Work Lib:
> - file_tool.py contain functions for dealing with file.
> - simple_log.py contain functions for a simple log.
> - ssh_client.py contain functions for creating SSH client to perform function on the remote computer.
## How to Deploy Package to Pypi Manually
bash
pip freeze > requirements.txt
python setup.py sdist bdist_wheel
twine check dist/*
twine upload --repository-url https://test.pypi.org/legacy/ dist/*
twine upload dist/*
## How to Install Dependencies
bash
py -m venv venv
.\venv\Scripts\activate
pip install -r .\requirements.txt
© 2021
%package -n python3-speedup-work-lib
Summary: A Python library to speed up work
Provides: python-speedup-work-lib
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-speedup-work-lib
# Speedup-Work-Lib
This repo is a library for speed up work
## Get Started
> There are **3 COMPONENTS** in Speedup Work Lib:
> - file_tool.py contain functions for dealing with file.
> - simple_log.py contain functions for a simple log.
> - ssh_client.py contain functions for creating SSH client to perform function on the remote computer.
## How to Deploy Package to Pypi Manually
bash
pip freeze > requirements.txt
python setup.py sdist bdist_wheel
twine check dist/*
twine upload --repository-url https://test.pypi.org/legacy/ dist/*
twine upload dist/*
## How to Install Dependencies
bash
py -m venv venv
.\venv\Scripts\activate
pip install -r .\requirements.txt
© 2021
%package help
Summary: Development documents and examples for speedup-work-lib
Provides: python3-speedup-work-lib-doc
%description help
# Speedup-Work-Lib
This repo is a library for speed up work
## Get Started
> There are **3 COMPONENTS** in Speedup Work Lib:
> - file_tool.py contain functions for dealing with file.
> - simple_log.py contain functions for a simple log.
> - ssh_client.py contain functions for creating SSH client to perform function on the remote computer.
## How to Deploy Package to Pypi Manually
bash
pip freeze > requirements.txt
python setup.py sdist bdist_wheel
twine check dist/*
twine upload --repository-url https://test.pypi.org/legacy/ dist/*
twine upload dist/*
## How to Install Dependencies
bash
py -m venv venv
.\venv\Scripts\activate
pip install -r .\requirements.txt
© 2021
%prep
%autosetup -n speedup_work_lib-0.3.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-speedup-work-lib -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.3.2-1
- Package Spec generated