%global _empty_manifest_terminate_build 0
Name: python-bcferries
Version: 0.1.2
Release: 1
Summary: BC Ferries Python Library
License: MIT
URL: http://yasyf.github.io/bcferries/
Source0: https://mirrors.aliyun.com/pypi/web/packages/6a/af/b3e2041a5c1bb8674a3db85a6fcf8397ac31b99f4beed91d2a2ca923947f/bcferries-0.1.2.tar.gz
BuildArch: noarch
%description
This is the Python client library for interacting with information
published on the `BC Ferries mobile
site `__. It is essentially a wrapper
around a BeautifulSoup-powered scraper. Better documentation and tests
are still in the works; feel free to contribute!
This library is used to power project like
`FerryTime `__. The source code for this library can
be found at `yasyf/bcferries `__ on
GitHub.
%package -n python3-bcferries
Summary: BC Ferries Python Library
Provides: python-bcferries
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bcferries
This is the Python client library for interacting with information
published on the `BC Ferries mobile
site `__. It is essentially a wrapper
around a BeautifulSoup-powered scraper. Better documentation and tests
are still in the works; feel free to contribute!
This library is used to power project like
`FerryTime `__. The source code for this library can
be found at `yasyf/bcferries `__ on
GitHub.
%package help
Summary: Development documents and examples for bcferries
Provides: python3-bcferries-doc
%description help
This is the Python client library for interacting with information
published on the `BC Ferries mobile
site `__. It is essentially a wrapper
around a BeautifulSoup-powered scraper. Better documentation and tests
are still in the works; feel free to contribute!
This library is used to power project like
`FerryTime `__. The source code for this library can
be found at `yasyf/bcferries `__ on
GitHub.
%prep
%autosetup -n bcferries-0.1.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bcferries -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.2-1
- Package Spec generated