%global _empty_manifest_terminate_build 0
Name: python-Baygon
Version: 0.5.1
Release: 1
Summary: Functional tests for teaching activities
License: MIT
URL: https://github.com/heig-tin-info/baygon
Source0: https://mirrors.aliyun.com/pypi/web/packages/0b/12/6fb5e5e197a075016577a5e4dfe08f4e5ab801d0cd9458ad01f0e579db09/Baygon-0.5.1.tar.gz
BuildArch: noarch
%description
# Baygon
[![GitHub issues](https://img.shields.io/github/issues/heig-tin-info/baygon.svg)](https://github.com/heig-tin-info/baygon/issues)
[![GitHub last commit](https://img.shields.io/github/last-commit/heig-tin-info/baygon.svg)](https://github.com/heig-tin-info/baygon/commits/master)
![Build and Deploy](https://github.com/heig-tin-info/baygon/workflows/Build%20and%20Deploy/badge.svg)
![Python](https://img.shields.io/pypi/pyversions/baygon)
**K**ills **B**ugs **D**ead!
This package is a minimalist functional test suite for binaries. It relies on a description of tests usually in `test.yml` or `test.json`.
The **documentation** is available [here](https://heig-tin-info.github.io/baygon/).
## Test file format
It can be either a `.yml` or a `.json` file.
```yml
version: 1
tests:
- name: Arguments check
tests:
- name: No errors if two arguments
args: [1, 2]
exit: 0
- name: Error if less than two arguments
args: [1]
exit: 1
- name: Stdout is the sum of arguments
args: [1, 2]
stdout: []
- name: Version on stderr
args: ['--version']
stderr:
- regex: '\b\d\.\d\.\d\b'
- contains: 'Version'
```
## Usage
```console
$ info-test -v ./a.out
Test 1: Arguments check
Test 1.1: No errors if two arguments................ PASSED
Test 1.2: Error if less than two arguments.......... PASSED
Test 2: Stdout is the sum of arguments.................. PASSED
Test 3: Version on stderr............................... PASSED
Ran 4 tests in 0.0s.
ok.
```
## How to install?
```console
pip3 install -U baygon
```
## Build documentation
The documentation is build upon VuePress.
```console
cd docs
yarn install
yarn docs:build
yarn docs:dev
```
## Contributing ?
```console
sudo apt update python-venv
git clone https://github.com/heig-tin-info/baygon.git
cd baygon
python -m venv env
source env/bin/activate
pip install -e .
```
%package -n python3-Baygon
Summary: Functional tests for teaching activities
Provides: python-Baygon
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Baygon
# Baygon
[![GitHub issues](https://img.shields.io/github/issues/heig-tin-info/baygon.svg)](https://github.com/heig-tin-info/baygon/issues)
[![GitHub last commit](https://img.shields.io/github/last-commit/heig-tin-info/baygon.svg)](https://github.com/heig-tin-info/baygon/commits/master)
![Build and Deploy](https://github.com/heig-tin-info/baygon/workflows/Build%20and%20Deploy/badge.svg)
![Python](https://img.shields.io/pypi/pyversions/baygon)
**K**ills **B**ugs **D**ead!
This package is a minimalist functional test suite for binaries. It relies on a description of tests usually in `test.yml` or `test.json`.
The **documentation** is available [here](https://heig-tin-info.github.io/baygon/).
## Test file format
It can be either a `.yml` or a `.json` file.
```yml
version: 1
tests:
- name: Arguments check
tests:
- name: No errors if two arguments
args: [1, 2]
exit: 0
- name: Error if less than two arguments
args: [1]
exit: 1
- name: Stdout is the sum of arguments
args: [1, 2]
stdout: []
- name: Version on stderr
args: ['--version']
stderr:
- regex: '\b\d\.\d\.\d\b'
- contains: 'Version'
```
## Usage
```console
$ info-test -v ./a.out
Test 1: Arguments check
Test 1.1: No errors if two arguments................ PASSED
Test 1.2: Error if less than two arguments.......... PASSED
Test 2: Stdout is the sum of arguments.................. PASSED
Test 3: Version on stderr............................... PASSED
Ran 4 tests in 0.0s.
ok.
```
## How to install?
```console
pip3 install -U baygon
```
## Build documentation
The documentation is build upon VuePress.
```console
cd docs
yarn install
yarn docs:build
yarn docs:dev
```
## Contributing ?
```console
sudo apt update python-venv
git clone https://github.com/heig-tin-info/baygon.git
cd baygon
python -m venv env
source env/bin/activate
pip install -e .
```
%package help
Summary: Development documents and examples for Baygon
Provides: python3-Baygon-doc
%description help
# Baygon
[![GitHub issues](https://img.shields.io/github/issues/heig-tin-info/baygon.svg)](https://github.com/heig-tin-info/baygon/issues)
[![GitHub last commit](https://img.shields.io/github/last-commit/heig-tin-info/baygon.svg)](https://github.com/heig-tin-info/baygon/commits/master)
![Build and Deploy](https://github.com/heig-tin-info/baygon/workflows/Build%20and%20Deploy/badge.svg)
![Python](https://img.shields.io/pypi/pyversions/baygon)
**K**ills **B**ugs **D**ead!
This package is a minimalist functional test suite for binaries. It relies on a description of tests usually in `test.yml` or `test.json`.
The **documentation** is available [here](https://heig-tin-info.github.io/baygon/).
## Test file format
It can be either a `.yml` or a `.json` file.
```yml
version: 1
tests:
- name: Arguments check
tests:
- name: No errors if two arguments
args: [1, 2]
exit: 0
- name: Error if less than two arguments
args: [1]
exit: 1
- name: Stdout is the sum of arguments
args: [1, 2]
stdout: []
- name: Version on stderr
args: ['--version']
stderr:
- regex: '\b\d\.\d\.\d\b'
- contains: 'Version'
```
## Usage
```console
$ info-test -v ./a.out
Test 1: Arguments check
Test 1.1: No errors if two arguments................ PASSED
Test 1.2: Error if less than two arguments.......... PASSED
Test 2: Stdout is the sum of arguments.................. PASSED
Test 3: Version on stderr............................... PASSED
Ran 4 tests in 0.0s.
ok.
```
## How to install?
```console
pip3 install -U baygon
```
## Build documentation
The documentation is build upon VuePress.
```console
cd docs
yarn install
yarn docs:build
yarn docs:dev
```
## Contributing ?
```console
sudo apt update python-venv
git clone https://github.com/heig-tin-info/baygon.git
cd baygon
python -m venv env
source env/bin/activate
pip install -e .
```
%prep
%autosetup -n Baygon-0.5.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Baygon -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.5.1-1
- Package Spec generated