%global _empty_manifest_terminate_build 0
Name: python-igloo-python
Version: 1.0.18
Release: 1
Summary: Python SDK for Igloo
License: MIT
URL: https://github.com/IglooCloud/igloo_python
Source0: https://mirrors.aliyun.com/pypi/web/packages/c0/6f/46599a7ae40a25cb3fa7e5bb7f2f396ef9576446ccf9e957b4b871a8fece/igloo-python-1.0.18.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-asyncio
Requires: python3-pathlib
Requires: python3-websockets
Requires: python3-aiodataloader
Requires: python3-aiohttp
%description
Python SDK for Igloo
## Getting started
Install the library with pip:
```
pip install igloo-python
```
You can find detailed documentation and examples on how to use the library on [our official site](http://igloo.ooo/).
## License
See the [license](https://github.com/IglooCloud/igloo-python/blob/master/LICENSE.txt) file for license rights and limitations.
%package -n python3-igloo-python
Summary: Python SDK for Igloo
Provides: python-igloo-python
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-igloo-python
Python SDK for Igloo
## Getting started
Install the library with pip:
```
pip install igloo-python
```
You can find detailed documentation and examples on how to use the library on [our official site](http://igloo.ooo/).
## License
See the [license](https://github.com/IglooCloud/igloo-python/blob/master/LICENSE.txt) file for license rights and limitations.
%package help
Summary: Development documents and examples for igloo-python
Provides: python3-igloo-python-doc
%description help
Python SDK for Igloo
## Getting started
Install the library with pip:
```
pip install igloo-python
```
You can find detailed documentation and examples on how to use the library on [our official site](http://igloo.ooo/).
## License
See the [license](https://github.com/IglooCloud/igloo-python/blob/master/LICENSE.txt) file for license rights and limitations.
%prep
%autosetup -n igloo-python-1.0.18
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-igloo-python -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.18-1
- Package Spec generated