%global _empty_manifest_terminate_build 0
Name: python-scikit-cuda
Version: 0.5.3
Release: 1
Summary: Python interface to GPU-powered libraries
License: BSD
URL: https://github.com/lebedov/scikit-cuda/
Source0: https://mirrors.aliyun.com/pypi/web/packages/92/6c/14183b058bcfc3133d1c968ddb670336ae8d7ca2f56966fbafa1b8e7039b/scikit-cuda-0.5.3.tar.gz
BuildArch: noarch
Requires: python3-mako
Requires: python3-numpy
Requires: python3-pycuda
Requires: python3-scipy
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
%description
scikit-cuda provides Python interfaces to many of the functions in the CUDA
device/runtime, CUBLAS, CUFFT, and CUSOLVER libraries distributed as part of
NVIDIA's `CUDA Programming Toolkit `_, as well as
interfaces to select functions in the `CULA Dense Toolkit `_.
Both low-level wrapper functions similar to their C counterparts and high-level
functions comparable to those in `NumPy and Scipy `_ are provided.
%package -n python3-scikit-cuda
Summary: Python interface to GPU-powered libraries
Provides: python-scikit-cuda
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-scikit-cuda
scikit-cuda provides Python interfaces to many of the functions in the CUDA
device/runtime, CUBLAS, CUFFT, and CUSOLVER libraries distributed as part of
NVIDIA's `CUDA Programming Toolkit `_, as well as
interfaces to select functions in the `CULA Dense Toolkit `_.
Both low-level wrapper functions similar to their C counterparts and high-level
functions comparable to those in `NumPy and Scipy `_ are provided.
%package help
Summary: Development documents and examples for scikit-cuda
Provides: python3-scikit-cuda-doc
%description help
scikit-cuda provides Python interfaces to many of the functions in the CUDA
device/runtime, CUBLAS, CUFFT, and CUSOLVER libraries distributed as part of
NVIDIA's `CUDA Programming Toolkit `_, as well as
interfaces to select functions in the `CULA Dense Toolkit `_.
Both low-level wrapper functions similar to their C counterparts and high-level
functions comparable to those in `NumPy and Scipy `_ are provided.
%prep
%autosetup -n scikit-cuda-0.5.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-scikit-cuda -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.5.3-1
- Package Spec generated