%global _empty_manifest_terminate_build 0
Name: python-clickpoints
Version: 1.10.0
Release: 1
Summary: Scientific toolbox for manual and automatic image evaluation.
License: GPLv3
URL: https://github.com/fabrylab/clickpoints
Source0: https://mirrors.aliyun.com/pypi/web/packages/58/1c/15d624e6f969a636aa934088b441ab8a9a6461f1a557ea51d26a28032c0d/clickpoints-1.10.0.tar.gz
BuildArch: noarch
Requires: python3-scipy
Requires: python3-matplotlib
Requires: python3-imageio
Requires: python3-QtPy
Requires: python3-QtAwesome
Requires: python3-qimage2ndarray
Requires: python3-Pillow
Requires: python3-peewee
Requires: python3-natsort
Requires: python3-tifffile
Requires: python3-imagecodecs
Requires: python3-sortedcontainers
Requires: python3-psutil
Requires: python3-imageio-ffmpeg
Requires: python3-qasync
Requires: python3-PyQt5
Requires: python3-dateutil
Requires: python3-scikit-image
Requires: python3-sphinx-rtd-theme
Requires: python3-sphinxcontrib-bibtex
Requires: python3-sphinxcontrib-svg2pdfconverter
Requires: python3-nbsphinx
Requires: python3-mock
%description
.. -*- mode: rst -*-
|ClickPoints|
.. |ClickPoints| image:: https://github.com/fabrylab/clickpoints/blob/master/docs/images/Logo.png
|DOC|_ |Python36| |License|_ |DOI|_
.. |DOC| image:: https://readthedocs.org/projects/clickpoints/badge/
.. _DOC: http://clickpoints.readthedocs.io
.. |Python36| image:: https://img.shields.io/badge/python-3.6-blue.svg
.. |License| image:: https://img.shields.io/badge/License-GPLv3-blue.svg
.. _License: http://www.gnu.org/licenses/gpl-3.0.html
.. |DOI| image:: https://img.shields.io/badge/DOI-10.1111/2041--210X.12702-blue.svg
.. _DOI: http://onlinelibrary.wiley.com/doi/10.1111/2041-210X.12702/full
Click Points is a program written in the Python programming language, which serves on the one hand as an image viewer and on the other hand as an data display and annotation tool. Every frame can be annotated by a description, marked points/tracks, or marked areas (paint brush). This helps to view image data, do manual evaluation of data, helps to create semi-automatic evaluation or display the results of automatic image evaluation.
Please refere to our `Documentation `_ for more information and instructions on installing it.
%package -n python3-clickpoints
Summary: Scientific toolbox for manual and automatic image evaluation.
Provides: python-clickpoints
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-clickpoints
.. -*- mode: rst -*-
|ClickPoints|
.. |ClickPoints| image:: https://github.com/fabrylab/clickpoints/blob/master/docs/images/Logo.png
|DOC|_ |Python36| |License|_ |DOI|_
.. |DOC| image:: https://readthedocs.org/projects/clickpoints/badge/
.. _DOC: http://clickpoints.readthedocs.io
.. |Python36| image:: https://img.shields.io/badge/python-3.6-blue.svg
.. |License| image:: https://img.shields.io/badge/License-GPLv3-blue.svg
.. _License: http://www.gnu.org/licenses/gpl-3.0.html
.. |DOI| image:: https://img.shields.io/badge/DOI-10.1111/2041--210X.12702-blue.svg
.. _DOI: http://onlinelibrary.wiley.com/doi/10.1111/2041-210X.12702/full
Click Points is a program written in the Python programming language, which serves on the one hand as an image viewer and on the other hand as an data display and annotation tool. Every frame can be annotated by a description, marked points/tracks, or marked areas (paint brush). This helps to view image data, do manual evaluation of data, helps to create semi-automatic evaluation or display the results of automatic image evaluation.
Please refere to our `Documentation `_ for more information and instructions on installing it.
%package help
Summary: Development documents and examples for clickpoints
Provides: python3-clickpoints-doc
%description help
.. -*- mode: rst -*-
|ClickPoints|
.. |ClickPoints| image:: https://github.com/fabrylab/clickpoints/blob/master/docs/images/Logo.png
|DOC|_ |Python36| |License|_ |DOI|_
.. |DOC| image:: https://readthedocs.org/projects/clickpoints/badge/
.. _DOC: http://clickpoints.readthedocs.io
.. |Python36| image:: https://img.shields.io/badge/python-3.6-blue.svg
.. |License| image:: https://img.shields.io/badge/License-GPLv3-blue.svg
.. _License: http://www.gnu.org/licenses/gpl-3.0.html
.. |DOI| image:: https://img.shields.io/badge/DOI-10.1111/2041--210X.12702-blue.svg
.. _DOI: http://onlinelibrary.wiley.com/doi/10.1111/2041-210X.12702/full
Click Points is a program written in the Python programming language, which serves on the one hand as an image viewer and on the other hand as an data display and annotation tool. Every frame can be annotated by a description, marked points/tracks, or marked areas (paint brush). This helps to view image data, do manual evaluation of data, helps to create semi-automatic evaluation or display the results of automatic image evaluation.
Please refere to our `Documentation `_ for more information and instructions on installing it.
%prep
%autosetup -n clickpoints-1.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-clickpoints -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.10.0-1
- Package Spec generated