summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 04:18:02 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 04:18:02 +0000
commit161c8bd57caa3c7e32d2077598df66ffa228d424 (patch)
tree71bc54de9501c98cd17d0724a052c1ae45352357
parent64819751e6078d3b18468d69e28bd038f25084fb (diff)
automatic import of python-openwrt-luci-rpcopeneuler20.03
-rw-r--r--.gitignore1
-rw-r--r--python-openwrt-luci-rpc.spec75
-rw-r--r--sources1
3 files changed, 77 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
index e69de29..a5fc32e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1 @@
+/openwrt-luci-rpc-1.1.16.tar.gz
diff --git a/python-openwrt-luci-rpc.spec b/python-openwrt-luci-rpc.spec
new file mode 100644
index 0000000..00d078f
--- /dev/null
+++ b/python-openwrt-luci-rpc.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-openwrt-luci-rpc
+Version: 1.1.16
+Release: 1
+Summary: Module for interacting with OpenWrt Luci RPC interface
+License: Apache Software License 2.0
+URL: https://github.com/fbradyirl/openwrt-luci-rpc
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/0f/5596ac3e9a11fbcef9132e8b3c15a0d978d5bc0ebc66cef27d0446d8c798/openwrt-luci-rpc-1.1.16.tar.gz
+BuildArch: noarch
+
+Requires: python3-Click
+Requires: python3-requests
+Requires: python3-packaging
+
+%description
+
+
+%package -n python3-openwrt-luci-rpc
+Summary: Module for interacting with OpenWrt Luci RPC interface
+Provides: python-openwrt-luci-rpc
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-openwrt-luci-rpc
+
+
+%package help
+Summary: Development documents and examples for openwrt-luci-rpc
+Provides: python3-openwrt-luci-rpc-doc
+%description help
+
+
+%prep
+%autosetup -n openwrt-luci-rpc-1.1.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-openwrt-luci-rpc -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.16-1
+- Package Spec generated
diff --git a/sources b/sources
new file mode 100644
index 0000000..55dd4ac
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+6baccd5a2d80715694a4d1a7cfceef56 openwrt-luci-rpc-1.1.16.tar.gz