summaryrefslogtreecommitdiff
path: root/ros-jazzy-nao-button-sim.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-01-16 10:45:02 +0000
committerCoprDistGit <infra@openeuler.org>2025-01-16 10:45:02 +0000
commit979fa1602291f7a069ce504d41f355cc558f8575 (patch)
tree2e7a6ba5687e27946db33cf721294f6670213c9a /ros-jazzy-nao-button-sim.spec
parentd4e2f8b9d57b65f37df5b43687ff59246825c28c (diff)
automatic import of Ros-jazzy-nao_button_simopeneuler24.03_LTS
Diffstat (limited to 'ros-jazzy-nao-button-sim.spec')
-rw-r--r--ros-jazzy-nao-button-sim.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/ros-jazzy-nao-button-sim.spec b/ros-jazzy-nao-button-sim.spec
new file mode 100644
index 0000000..5e5ff9e
--- /dev/null
+++ b/ros-jazzy-nao-button-sim.spec
@@ -0,0 +1,82 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/jazzy/.*$
+%global __requires_exclude_from ^/opt/ros/jazzy/.*$
+%global debug_package %{nil}
+
+Name: ros-jazzy-nao-button-sim
+Version: 1.0.1
+Release: 0%{?dist}%{?release_suffix}
+Summary: ROS nao_button_sim package
+
+License: Apache License 2.0
+Source0: %{name}-%{version}.tar.gz
+
+BuildRequires: ros-jazzy-ament-package
+Requires: ros-jazzy-nao-lola-sensor-msgs
+BuildRequires: python%{python3_pkgversion}-devel
+BuildRequires: ros-jazzy-nao-lola-sensor-msgs
+
+%if 0%{?with_tests}
+BuildRequires: python3-pytest
+BuildRequires: ros-jazzy-ament-copyright
+BuildRequires: ros-jazzy-ament-flake8
+BuildRequires: ros-jazzy-ament-pep257
+BuildRequires: ros-jazzy-ament-package
+%endif
+
+%description
+Allows simulating button presses through command line interface
+
+%prep
+%autosetup -p1
+
+%build
+# 修复 PYTHONPATH 环境变量
+export PYTHONPATH=/opt/ros/jazzy/lib/python3.11/site-packages:$PYTHONPATH
+
+# 修复 CMAKE_PREFIX_PATH 和 PKG_CONFIG_PATH
+export CMAKE_PREFIX_PATH=/opt/ros/jazzy
+export PKG_CONFIG_PATH=/opt/ros/jazzy/lib/pkgconfig
+export rcutils_DIR=/opt/ros/jazzy/opt/ros/jazzy/share/rcutils/cmake
+
+# 输出环境变量以验证设置
+echo "PYTHONPATH: $PYTHONPATH"
+echo "CMAKE_PREFIX_PATH: $CMAKE_PREFIX_PATH"
+echo "PKG_CONFIG_PATH: $PKG_CONFIG_PATH"
+
+# 验证 ament_package 是否可用
+python3 -c "import ament_package" || { echo "ament_package not found"; exit 1; }
+
+# 创建构建目录并进入
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+
+%install
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/jazzy/setup.sh" ]; then . "/opt/ros/jazzy/setup.sh"; fi
+%py3_install -- --prefix "/opt/ros/jazzy"
+
+%if 0%{?with_tests}
+%check
+# 检查是否存在测试目录或文件
+if [ -d "tests" ] || ls test_*.py *_test.py > /dev/null 2>&1; then
+ # 加载安装目录的 setup.sh 文件(如果存在)
+ if [ -f "/opt/ros/jazzy/setup.sh" ]; then
+ . "/opt/ros/jazzy/setup.sh"
+ fi
+ %__python3 -m pytest tests || echo "RPM TESTS FAILED"
+else
+ echo "No tests to run, skipping."
+fi
+%endif
+
+%files
+/opt/ros/jazzy/*
+
+%changelog
+* Mon Jan 06 2025 ijnek <kenjibrameld@gmail.com> - 1.0.1-0
+- Autogenerated by Bloom