summaryrefslogtreecommitdiff
path: root/ros-jazzy-rtcm-msgs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'ros-jazzy-rtcm-msgs.spec')
-rw-r--r--ros-jazzy-rtcm-msgs.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/ros-jazzy-rtcm-msgs.spec b/ros-jazzy-rtcm-msgs.spec
new file mode 100644
index 0000000..df1dcb4
--- /dev/null
+++ b/ros-jazzy-rtcm-msgs.spec
@@ -0,0 +1,104 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/jazzy/.*$
+%global __requires_exclude_from ^/opt/ros/jazzy/.*$
+%global debug_package %{nil}
+
+Name: ros-jazzy-rtcm-msgs
+Version: 1.1.6
+Release: 0%{?dist}%{?release_suffix}
+Summary: ROS rtcm_msgs package
+
+License: BSD
+Source0: %{name}-%{version}.tar.gz
+
+BuildRequires: ros-jazzy-ament-package
+Requires: ros-jazzy-rosidl-default-runtime
+Requires: ros-jazzy-std-msgs
+BuildRequires: ros-jazzy-ament-cmake
+BuildRequires: ros-jazzy-builtin-interfaces
+BuildRequires: ros-jazzy-ros-environment
+BuildRequires: ros-jazzy-rosidl-default-generators
+BuildRequires: ros-jazzy-std-msgs
+
+%if 0%{?with_tests}
+BuildRequires: ros-jazzy-ament-lint-common
+BuildRequires: ros-jazzy-ament-package
+%endif
+
+%description
+The rtcm_msgs package contains messages related to data in the RTCM format.
+
+%prep
+%autosetup -p1
+
+%build
+export ROS_VERSION=2
+
+export ROS_DISTRO=jazzy
+
+
+
+echo "ROS_VERSION: $ROS_VERSION"
+
+echo "ROS_DISTRO: $ROS_DISTRO"
+# 修复 PYTHONPATH 环境变量
+export PYTHONPATH=/opt/ros/jazzy/lib/python3.11/site-packages:$PYTHONPATH
+
+# 修复 CMAKE_PREFIX_PATH 和 PKG_CONFIG_PATH
+export CMAKE_PREFIX_PATH=/opt/ros/jazzy
+export PKG_CONFIG_PATH=/opt/ros/jazzy/lib/pkgconfig
+export rcutils_DIR=/opt/ros/jazzy/opt/ros/jazzy/share/rcutils/cmake
+
+# 输出环境变量以验证设置
+echo "PYTHONPATH: $PYTHONPATH"
+echo "CMAKE_PREFIX_PATH: $CMAKE_PREFIX_PATH"
+echo "PKG_CONFIG_PATH: $PKG_CONFIG_PATH"
+
+# 验证 ament_package 是否可用
+python3 -c "import ament_package" || { echo "ament_package not found"; exit 1; }
+
+# 创建构建目录并进入
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+ -UINCLUDE_INSTALL_DIR \
+ -ULIB_INSTALL_DIR \
+ -USYSCONF_INSTALL_DIR \
+ -USHARE_INSTALL_PREFIX \
+ -ULIB_SUFFIX \
+ -DCMAKE_INSTALL_PREFIX="/opt/ros/jazzy" \
+ -DAMENT_PREFIX_PATH="/opt/ros/jazzy" \
+ -DCMAKE_PREFIX_PATH="/opt/ros/jazzy" \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+ -DBUILD_TESTING=OFF \
+%endif
+ ..
+
+%make_build
+
+%install
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/jazzy/setup.sh" ]; then . "/opt/ros/jazzy/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# 检查是否存在测试目录或文件
+if [ -d "tests" ] || ls test_*.py *_test.py > /dev/null 2>&1; then
+ %__python3 -m pytest tests || echo "RPM TESTS FAILED"
+else
+ echo "No tests to run, skipping."
+fi
+%endif
+
+%files
+/opt/ros/jazzy/*
+
+%changelog
+* Sun Dec 22 2024 Marek Materzok <tilk@tilk.eu> - 1.1.6-0
+- Autogenerated by Bloom