summaryrefslogtreecommitdiff
path: root/rust-ripgrep.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rust-ripgrep.spec')
-rw-r--r--rust-ripgrep.spec39
1 files changed, 39 insertions, 0 deletions
diff --git a/rust-ripgrep.spec b/rust-ripgrep.spec
new file mode 100644
index 0000000..b1906f5
--- /dev/null
+++ b/rust-ripgrep.spec
@@ -0,0 +1,39 @@
+%global debug_package %{nil}
+%global crate_name ripgrep
+
+Name: rust-ripgrep
+Version: 14.1.0
+Release: 1
+Summary: Line-oriented search tool
+License: Unlicense OR MIT
+URL: https://crates.io/crates/cbindgen
+Source0: https://github.com/BurntSushi/ripgrep/archive/refs/tags/%{version}.tar.gz
+Source1: vendor.tar.xz
+Source2: cargo_config
+
+%global _description %{expand:
+Ripgrep is a line-oriented search tool that recursively searches the
+current directory for a regex pattern while respecting gitignore rules.
+ripgrep has first class support on Windows, macOS and Linux.}
+
+%description %{_description}
+
+%prep
+%setup -q -T -b 0 -n %{crate_name}-%{version}
+%setup -q -D -T -a 1 -n %{crate_name}-%{version}
+cp %{SOURCE2} .cargo/config.toml
+
+%build
+cargo build --release
+
+%install
+export CARGO_HOME=`pwd`/cargo-home/
+# cargo install appends /bin to the path
+cargo install --root=%{buildroot}%{_prefix} --path .
+# remove spurious files
+rm -f %{buildroot}%{_prefix}/.crates.toml
+rm -f %{buildroot}%{_prefix}/.crates2.json
+
+%files
+%license UNLICENSE
+%{_bindir}/rg