summaryrefslogtreecommitdiff
path: root/yarnpkg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'yarnpkg.spec')
-rw-r--r--yarnpkg.spec41
1 files changed, 41 insertions, 0 deletions
diff --git a/yarnpkg.spec b/yarnpkg.spec
new file mode 100644
index 0000000..2301e1d
--- /dev/null
+++ b/yarnpkg.spec
@@ -0,0 +1,41 @@
+%global debug_package %{nil}
+%global npm_name yarn
+
+%global __requires_exclude_from ^(%{nodejs_sitelib}/yarn/lib/.*|%{nodejs_sitelib}/yarn/bin/yarn(|\\.cmd|\\.ps1|pkg.*))$
+
+Name: yarnpkg
+Version: 1.22.22
+Release: 1
+Summary: Fast, reliable, and secure dependency management.
+
+License: BSD-2-Clause
+URL: https://github.com/yarnpkg/yarn
+Source0: https://github.com/yarnpkg/yarn/releases/download/v%{version}/yarn-v%{version}.tar.gz
+
+Requires: nodejs
+BuildRequires: npm
+
+%description
+Fast, reliable, and secure dependency management.
+
+
+%prep
+%setup -q -n yarn-v%{version}
+
+
+%build
+
+
+%install
+npm i -g --prefix="%{buildroot}/usr" %{SOURCE0}
+
+rm -rfv %{buildroot}/etc/
+
+
+%files
+%doc README.md
+%license LICENSE
+
+%{_bindir}/yarnpkg
+%{_bindir}/yarn
+%{nodejs_sitelib}/%{npm_name}/