summaryrefslogtreecommitdiff
path: root/python-ceph-deploy.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-04 15:30:22 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-04 15:30:22 +0000
commit2730b2359e85173087ca731ec5d7e8bba6dc456a (patch)
treecd67693c07d08aaf986bea43cf8df9efd518748d /python-ceph-deploy.spec
parentc49c10b726857d95b0ed879d3a4067dc6d70556e (diff)
automatic import of python-ceph-deployopeneuler20.03
Diffstat (limited to 'python-ceph-deploy.spec')
-rw-r--r--python-ceph-deploy.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-ceph-deploy.spec b/python-ceph-deploy.spec
new file mode 100644
index 0000000..ac89936
--- /dev/null
+++ b/python-ceph-deploy.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ceph-deploy
+Version: 2.1.0
+Release: 2
+Summary: Deploy Ceph with minimal infrastructure
+License: MIT
+URL: https://github.com/ceph/ceph-deploy
+Source0: https://github.com/ceph/ceph-deploy/archive/refs/tags/v2.1.0.tar.gz
+BuildArch: noarch
+Patch1: 0001-py2-to-py3.patch
+
+
+%description
+
+
+%package -n python3-ceph-deploy
+Summary: Deploy Ceph with minimal infrastructure
+Provides: python-ceph-deploy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+Requires: python3-remoto
+%description -n python3-ceph-deploy
+
+
+%package help
+Summary: Development documents and examples for ceph-deploy
+Provides: python3-ceph-deploy-doc
+%description help
+
+
+%prep
+%autosetup -p1 -n ceph-deploy-2.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ceph-deploy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 13 2022 wangzengliang<wangzengliang1@huawei.com> - 2.1.0-2
+- modify some code py2 to py3
+
+* Wed Apr 13 2022 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
+- Package Spec generated