summaryrefslogtreecommitdiff
path: root/python-botorch.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-botorch.spec')
-rw-r--r--python-botorch.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/python-botorch.spec b/python-botorch.spec
new file mode 100644
index 0000000..5f1685e
--- /dev/null
+++ b/python-botorch.spec
@@ -0,0 +1,57 @@
+%global pypi_name botorch
+%global pypi_version 0.10.0
+%global pkg_summary BoTorch is a library for Bayesian Optimization built on PyTorch.
+%global pkg_description %{expand:
+%{pkg_summary}}
+%global debug_package %{nil}
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1
+Summary: %{pkg_summary}
+
+License: MIT
+URL: https://github.com/pytorch/botorch
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/botorch-%{version}.tar.gz
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+BuildRequires: python3-pytorch >= 2.1.2
+BuildRequires: python3-gpytorch == 1.11
+BuildRequires: python3-linear_operator == 0.5.1
+BuildRequires: python3-pyro-ppl >= 1.8.4
+BuildRequires: python3-scipy
+BuildRequires: python3-multipledispatch
+
+%description
+%{pkg_description}
+
+%package -n python3-%{pypi_name}
+Summary: %{pkg_summary}
+
+%description -n python3-%{pypi_name}
+%{pkg_description}
+
+%prep
+%autosetup -p1 -n %{pypi_name}-%{pypi_version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.md
+%{python3_sitearch}/%{pypi_name}*
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add botorch 0.10.0