summaryrefslogtreecommitdiff
path: root/python-fvcore.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-fvcore.spec')
-rw-r--r--python-fvcore.spec65
1 files changed, 45 insertions, 20 deletions
diff --git a/python-fvcore.spec b/python-fvcore.spec
index 13e9995..3e84997 100644
--- a/python-fvcore.spec
+++ b/python-fvcore.spec
@@ -1,14 +1,14 @@
-%global pypi_name fvcore
-%global pypi_version 0.1.5
+%global pkg_name fvcore
+%global pkg_version 0.1.5
%global commit fd5043ff8b2e6790f5bd7c9632695c68986cc658
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global date 20221221
%global pkg_summary Collection of common code that's shared among different research projects in FAIR computer vision team.
%global pkg_description %{pkg_summary}
-%global debug_package %{nil}
+%global _empty_manifest_terminate_build 0
-Name: python-%{pypi_name}
-Version: %{pypi_version}^git%{date}.%{shortcommit}
+Name: python-%{pkg_name}
+Version: %{pkg_version}^git%{date}.%{shortcommit}
Release: 1%{?dist}
Summary: %{pkg_summary}
@@ -16,41 +16,66 @@ License: Apache-2.0 license
URL: https://github.com/facebookresearch/fvcore
Source0: %{url}/archive/%{commit}/fvcore-%{commit}.tar.gz#/fvcore-%{commit}.tar.gz
-BuildRequires: cmake
-BuildRequires: ninja-build
-BuildRequires: g++
+BuildRequires: cmake
+BuildRequires: ninja-build
+BuildRequires: g++
-BuildRequires: python3-devel
-BuildRequires: python3-setuptools
-BuildRequires: python3-setuptools_scm
-BuildRequires: python3-pbr
-BuildRequires: python3-pip
-BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
%description
%{pkg_description}
-%package -n python3-%{pypi_name}
+%package -n python3-%{pkg_name}
Summary: %{pkg_summary}
-%description -n python3-%{pypi_name}
+%description -n python3-%{pkg_name}
%{pkg_description}
+%package help
+Summary: the documents and examples for %{pkg_name}
+
+%description help
+This package contains the documents and examples for %{pkg_name}
+
%prep
-%autosetup -p1 -n %{pypi_name}-%{commit}
+%autosetup -p1 -n %{pkg_name}-%{pkg_version}
%build
%pyproject_build
%install
%pyproject_install
+# help pkg files:
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/doclist.lst .
-%files -n python3-%{pypi_name}
+%files -n python3-%{pkg_name}
%license LICENSE
%doc README.md
-%{python3_sitelib}/%{pypi_name}*
+%{python3_sitelib}/%{pkg_name}*
+
+%files help -f doclist.lst
+%{_docdir}/*
%changelog
+* Mon Apr 15 2024 YunShu
+- add help subpackage
+
* Sun Mar 31 2024 YunShu
- add fvcore 0.1.5