summaryrefslogtreecommitdiff
path: root/python-gpytorch.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-gpytorch.spec')
-rw-r--r--python-gpytorch.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/python-gpytorch.spec b/python-gpytorch.spec
new file mode 100644
index 0000000..fdc8d33
--- /dev/null
+++ b/python-gpytorch.spec
@@ -0,0 +1,52 @@
+%global pypi_name gpytorch
+%global pypi_version 1.11
+%global pkg_summary An implementation of Gaussian Processes in Pytorch
+%global pkg_description %{expand:
+%{pkg_summary}}
+%global debug_package %{nil}
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1
+Summary: %{pkg_summary}
+
+License: MIT
+URL: https://github.com/cornellius-gp/gpytorch
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/gpytorch-%{version}.tar.gz
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+BuildRequires: python3-pytorch >= 2.1.2
+
+%description
+%{pkg_description}
+
+%package -n python3-%{pypi_name}
+Summary: %{pkg_summary}
+
+%description -n python3-%{pypi_name}
+%{pkg_description}
+
+%prep
+%autosetup -p1 -n %{pypi_name}-%{pypi_version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.md
+%{python3_sitelib}/%{pypi_name}*
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add gpytorch 1.11