summaryrefslogtreecommitdiff
path: root/python-hatch-fancy-pypi-readme.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hatch-fancy-pypi-readme.spec')
-rw-r--r--python-hatch-fancy-pypi-readme.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/python-hatch-fancy-pypi-readme.spec b/python-hatch-fancy-pypi-readme.spec
new file mode 100644
index 0000000..dfa2a7d
--- /dev/null
+++ b/python-hatch-fancy-pypi-readme.spec
@@ -0,0 +1,55 @@
+%global _empty_manifest_terminate_build 0
+%global pypi_name hatch-fancy-pypi-readme
+%global source_name hatch_fancy_pypi_readme
+
+Name: python-%{pypi_name}
+Version: 24.1.0
+Release: 1
+Summary: An MIT-licensed metadata plugin for Hatch to help user to have fancy PyPI readmes.
+
+License: MIT
+URL: https://github.com/hynek/hatch-fancy-pypi-readme
+Source0: https://files.pythonhosted.org/packages/b4/c2/c9094283a07dd96c5a8f7a5f1910259d40d2e29223b95dd875a6ca13b58f/hatch_fancy_pypi_readme-24.1.0.tar.gz
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-editables
+BuildRequires: python3-hatch-vcs
+BuildRequires: python3-hatchling
+BuildRequires: python3-virtualenv
+
+%description
+An MIT-licensed metadata plugin for Hatch to help user to have fancy PyPI readmes.
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+
+%description -n python3-%{pypi_name}
+An MIT-licensed metadata plugin for Hatch to help user to have fancy PyPI readmes.
+
+%prep
+%autosetup -p1 -n %{source_name}-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%doc README.md
+%license LICENSE.txt
+%{_bindir}/hatch-fancy-pypi-readme
+%{python3_sitelib}/%{source_name}
+%{python3_sitelib}/%{source_name}*.dist-info/
+
+%changelog
+* Mon Mar 4 2024 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 24.1.0-1
+- Update package with version 24.1.0
+ Added a default to an internal API that is used by scikit-build-core.
+
+* Wed Jun 21 2023 zjyabsa <jyzhangcf@isoftstone.com> - 23.1.0-1
+- Initial package