summaryrefslogtreecommitdiff
path: root/python-hatch-requirements-txt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hatch-requirements-txt.spec')
-rw-r--r--python-hatch-requirements-txt.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/python-hatch-requirements-txt.spec b/python-hatch-requirements-txt.spec
new file mode 100644
index 0000000..d591416
--- /dev/null
+++ b/python-hatch-requirements-txt.spec
@@ -0,0 +1,55 @@
+%global _empty_manifest_terminate_build 0
+%global pypi_name hatch-requirements-txt
+%global source_name hatch_requirements_txt
+
+Name: python-%{pypi_name}
+Version: 0.4.1
+Release: 1
+Summary: Hatchling plugin to read project dependencies from requirements.txt.
+
+License: MIT
+URL: https://github.com/repo-helper/hatch-requirements-txt
+Source0: https://files.pythonhosted.org/packages/7c/04/3703d3caa354fd7148a5453724de70577a6010234d1e1f3ff6b98a4d3242/hatch_requirements_txt-0.4.1.tar.gz
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+%description
+Hatchling plugin to read project dependencies from requirements.txt.
+
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+
+%description -n python3-%{pypi_name}
+Hatchling plugin to read project dependencies from requirements.txt.
+
+
+%prep
+%autosetup -p1 -n %{source_name}-%{version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%doc README.rst
+%license LICENSE
+%{python3_sitelib}/hatch_requirements_txt
+%{python3_sitelib}/hatch_requirements_txt*.dist-info/
+
+%changelog
+* Tue Mar 12 2024 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 0.4.1-1
+- Update package to version 0.4.1
+ Updated files with 'repo_helper'.
+ Test on newer Python versions
+ Clarify that unsupported options are within requirements.txt, not generally.
+
+* Sun Jun 25 2023 Dongxing Wang <dxwangk@isoftstone.com> - 0.4.0-1
+- Initial package