summaryrefslogtreecommitdiff
path: root/python-iopath.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-04-13 12:40:03 +0000
committerCoprDistGit <infra@openeuler.org>2024-04-13 12:40:03 +0000
commitcadb4ba81afd7f835912186521536ade1d29f8f2 (patch)
treeec48c966aadb7585508f0dfc58ee1fc37c8ac622 /python-iopath.spec
parent7d9fe3bc2e129b8bc5c24b7bb322f769e798ce5f (diff)
automatic import of python-iopath
Diffstat (limited to 'python-iopath.spec')
-rw-r--r--python-iopath.spec18
1 files changed, 12 insertions, 6 deletions
diff --git a/python-iopath.spec b/python-iopath.spec
index be3757d..c67ebe2 100644
--- a/python-iopath.spec
+++ b/python-iopath.spec
@@ -1,13 +1,13 @@
%global pypi_name iopath
%global pypi_version 0.1.9
-%global pypi_summary Datasets, Transforms and Models specific to Computer Vision
-%global pypi_description %{pypi_summary}
+%global pkg_summary A python library that provides common I/O interface across different storage backends.
+%global pkg_description %{pkg_summary}
%global debug_package %{nil}
Name: python-%{pypi_name}
Version: %{pypi_version}
Release: 1%{?dist}
-Summary: %{pypi_summary}
+Summary: %{pkg_summary}
License: MIT License
URL: https://github.com/facebookresearch/iopath
@@ -18,15 +18,21 @@ BuildRequires: ninja-build
BuildRequires: g++
BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
%description
-%{pypi_description}
+%{pkg_description}
%package -n python3-%{pypi_name}
-Summary: %{pypi_summary}
+Summary: %{pkg_summary}
%description -n python3-%{pypi_name}
-%{pypi_description}
+%{pkg_description}
%prep
%autosetup -p1 -n %{pypi_name}-%{pypi_version}