summaryrefslogtreecommitdiff
path: root/python-linear-operator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-linear-operator.spec')
-rw-r--r--python-linear-operator.spec61
1 files changed, 43 insertions, 18 deletions
diff --git a/python-linear-operator.spec b/python-linear-operator.spec
index 7f4203c..5ed9bca 100644
--- a/python-linear-operator.spec
+++ b/python-linear-operator.spec
@@ -1,12 +1,12 @@
-%global pypi_name linear_operator
-%global pypi_version 0.5.1
+%global pkg_name linear_operator
+%global pkg_version 0.5.1
%global pkg_summary A linear operator implementation, primarily designed for finite-dimensional positive definite operators (i.e. kernel matrices).
%global pkg_description %{expand:
%{pkg_summary}}
-%global debug_package %{nil}
+%global _empty_manifest_terminate_build 0
-Name: python-%{pypi_name}
-Version: %{pypi_version}
+Name: python-%{pkg_name}
+Version: %{pkg_version}
Release: 1
Summary: %{pkg_summary}
@@ -16,40 +16,65 @@ Source0: https://files.pythonhosted.org/packages/7f/16/7ec06125b4ea863b0e
Patch1: 0001-remove-illegal-characters.patch
-BuildRequires: python3-devel
-BuildRequires: python3-setuptools
-BuildRequires: python3-setuptools_scm
-BuildRequires: python3-pbr
-BuildRequires: python3-pip
-BuildRequires: python3-wheel
-BuildRequires: python3-hatchling
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
-BuildRequires: python3-pytorch >= 2.1.2
-BuildRequires: python3-scipy
+BuildRequires: python3-pytorch >= 2.1.2
+BuildRequires: python3-scipy
%description
%{pkg_description}
-%package -n python3-%{pypi_name}
+%package -n python3-%{pkg_name}
Summary: %{pkg_summary}
-%description -n python3-%{pypi_name}
+%description -n python3-%{pkg_name}
%{pkg_description}
+%package help
+Summary: the documents and examples for %{pkg_name}
+
+%description help
+This package contains the documents and examples for %{pkg_name}
+
%prep
-%autosetup -p1 -n linear_operator-%{pypi_version}
+%autosetup -p1 -n linear_operator-%{pkg_version}
%build
%pyproject_build
%install
%pyproject_install
+# help pkg files:
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/doclist.lst .
-%files -n python3-%{pypi_name}
+%files -n python3-%{pkg_name}
%license LICENSE
%doc README.md
%{python3_sitelib}/linear_operator*
+%files help -f doclist.lst
+%{_docdir}/*
+
%changelog
+* Mon Apr 15 2024 YunShu
+- add help subpackage
+
* Sun Mar 31 2024 YunShu
- add linear-operator 0.5.1