summaryrefslogtreecommitdiff
path: root/python-pyro-api.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-04-14 11:04:21 +0000
committerCoprDistGit <infra@openeuler.org>2024-04-14 11:04:21 +0000
commit763d80659f3c89579067a56aad703533f7f16600 (patch)
tree8979deb04c8284710bb4f2fa72d7075b3af49e7c /python-pyro-api.spec
parent83f812fd9cfe9dbae2bc9325a825a65078dca1e1 (diff)
automatic import of python-pyro-api
Diffstat (limited to 'python-pyro-api.spec')
-rw-r--r--python-pyro-api.spec50
1 files changed, 50 insertions, 0 deletions
diff --git a/python-pyro-api.spec b/python-pyro-api.spec
new file mode 100644
index 0000000..bd701bd
--- /dev/null
+++ b/python-pyro-api.spec
@@ -0,0 +1,50 @@
+%global pypi_name pyro-api
+%global pypi_version 0.1.1
+%global pkg_summary Generic API for dispatch to Pyro backends.
+%global pkg_description %{expand:
+%{pkg_summary}}
+%global debug_package %{nil}
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1
+Summary: %{pkg_summary}
+
+License: Apache-2.0
+URL: https://github.com/pyro-ppl/pyro-api
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/pyro-api-%{version}.tar.gz
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+%description
+%{pkg_description}
+
+%package -n python3-%{pypi_name}
+Summary: %{pkg_summary}
+
+%description -n python3-%{pypi_name}
+%{pkg_description}
+
+%prep
+%autosetup -p1 -n %{pypi_name}-%{pypi_version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE*
+%doc README*
+%{python3_sitelib}/%{pypi_name}*
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add pyro-api 0.1.1