summaryrefslogtreecommitdiff
path: root/python-pytorch3d.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-03-31 15:43:37 +0000
committerCoprDistGit <infra@openeuler.org>2024-03-31 15:43:37 +0000
commit4a413f55e8459a3f8d55aec8e8c91d3f2eab84f3 (patch)
tree820cb4b82df7ebb2c5979694012326d7229e842a /python-pytorch3d.spec
parent4232fadf552af52f74768861b93b65f772b4de0d (diff)
automatic import of python-pytorch3d
Diffstat (limited to 'python-pytorch3d.spec')
-rw-r--r--python-pytorch3d.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/python-pytorch3d.spec b/python-pytorch3d.spec
new file mode 100644
index 0000000..2b22b8d
--- /dev/null
+++ b/python-pytorch3d.spec
@@ -0,0 +1,47 @@
+%global pypi_name pytorch3d
+%global pypi_version 0.7.5
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1%{?dist}
+Summary: PyTorch3D is FAIR's library of reusable components for deep learning with 3D data
+
+License: BSD 3-Clause
+URL: https://github.com/facebookresearch/pytorch3d
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/pytorch3d-%{version}.tar.gz
+
+BuildRequires: cmake
+BuildRequires: ninja-build
+
+BuildRequires: python3-tqdm
+BuildRequires: python3-requests
+BuildRequires: python3-devel
+BuildRequires: python3-pytorch >= 2.1.2
+
+%description
+PyTorch3D is FAIR's library of reusable components for deep learning with 3D data
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+
+%description -n python3-%{pypi_name}
+PyTorch3D is FAIR's library of reusable components for deep learning with 3D data
+
+%prep
+%autosetup -p1 -n pytorch3d-%{pypi_version}
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.md
+%{python3_sitelib}/%{pypi_name}
+%{python3_sitelib}/%{pypi_name}-*.egg-info/
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add pytorch3d