summaryrefslogtreecommitdiff
path: root/python-safetensors.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-safetensors.spec')
-rw-r--r--python-safetensors.spec15
1 files changed, 11 insertions, 4 deletions
diff --git a/python-safetensors.spec b/python-safetensors.spec
index b7ae3d9..c900bbf 100644
--- a/python-safetensors.spec
+++ b/python-safetensors.spec
@@ -3,6 +3,7 @@
%global pkg_summary Simple, safe way to store and distribute tensors
%global pkg_description %{expand:
%{pkg_summary}}
+%global debug_package %{nil}
Name: python-%{pypi_name}
Version: %{pypi_version}
@@ -40,11 +41,17 @@ mkdir -vp ${CARGO_HOME:-$HOME/.cargo}
cat << EOF | tee -a ${CARGO_HOME:-$HOME/.cargo}/config
[source.crates-io]
-replace-with = 'mirror'
-
-[source.mirror]
-registry = "https://mirrors.tuna.tsinghua.edu.cn/git/crates.io-index.git"
+replace-with = 'rsproxy-sparse'
+[source.rsproxy]
+registry = "https://rsproxy.cn/crates.io-index"
+[source.rsproxy-sparse]
+registry = "sparse+https://rsproxy.cn/index/"
+[registries.rsproxy]
+index = "https://rsproxy.cn/crates.io-index"
+[net]
+git-fetch-with-cli = true
EOF
+
%autosetup -p1 -n %{pypi_name}-%{pypi_version}
%build