summaryrefslogtreecommitdiff
path: root/python-tensordict.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-04-15 02:14:46 +0000
committerCoprDistGit <infra@openeuler.org>2024-04-15 02:14:46 +0000
commit1c24fa3250dcbcc33a7a606e0716061da33108d8 (patch)
tree1b202f97e91d753905f581482eae80331b187118 /python-tensordict.spec
parenta02769c7b05e6ec1fadd1007d1cd08a4ffe90e38 (diff)
automatic import of python-tensordict
Diffstat (limited to 'python-tensordict.spec')
-rw-r--r--python-tensordict.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-tensordict.spec b/python-tensordict.spec
new file mode 100644
index 0000000..f1067b8
--- /dev/null
+++ b/python-tensordict.spec
@@ -0,0 +1,72 @@
+%global pkg_name tensordict
+%global pkg_version 0.2.1
+%global pkg_summary TensorDict is a pytorch dedicated tensor container.
+%global pkg_description %{expand:
+%{pkg_summary}}
+# %global debug_package %{nil}
+
+Name: python-%{pkg_name}
+Version: %{pkg_version}
+Release: 1
+Summary: %{pkg_summary}
+
+License: MIT
+URL: https://github.com/pytorch/tensordict
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/tensordict-%{version}.tar.gz
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pbr
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+%description
+%{pkg_description}
+
+%package -n python3-%{pkg_name}
+Summary: %{pkg_summary}
+
+%description -n python3-%{pkg_name}
+%{pkg_description}
+
+%package doc
+Summary: the documentation for %{pkg_name}
+
+%description doc
+This package contains the documentation for %{pkg_name}
+
+%prep
+%autosetup -p1 -n %{pkg_name}-%{pkg_version}
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install
+# doc pkg:
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-%{pkg_name}
+%license LICENSE*
+%doc README*
+%{python3_sitelib}/%{pkg_name}*
+
+%files doc -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add tensordict 0.2.1