summaryrefslogtreecommitdiff
path: root/python-torchdata.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-torchdata.spec')
-rw-r--r--python-torchdata.spec5
1 files changed, 3 insertions, 2 deletions
diff --git a/python-torchdata.spec b/python-torchdata.spec
index 16a6735..5b3051e 100644
--- a/python-torchdata.spec
+++ b/python-torchdata.spec
@@ -29,6 +29,7 @@ BuildRequires: python3-pip
BuildRequires: python3-wheel
BuildRequires: python3-hatchling
+BuildRequires: python3-numpy
BuildRequires: python3-pytorch >= 2.1.2
%description
@@ -44,10 +45,10 @@ Summary: %{pkg_summary}
%autosetup -p1 -n data-%{pypi_version}
# unzip and move to third_party/aws-sdk-cpp
unzip -q %{SOURCE1}
-mv aws-sdk-cpp* third_party/aws-sdk-cpp
+mv aws-sdk-cpp*/* third_party/aws-sdk-cpp/
# unzip and move to third_party/pybind11
unzip -q %{SOURCE2}
-mv pybind11* third_party/pybind11
+mv pybind11*/* third_party/pybind11/
%build
%pyproject_build