summaryrefslogtreecommitdiff
path: root/python-torchdata.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-torchdata.spec')
-rw-r--r--python-torchdata.spec9
1 files changed, 9 insertions, 0 deletions
diff --git a/python-torchdata.spec b/python-torchdata.spec
index 274fb8f..16a6735 100644
--- a/python-torchdata.spec
+++ b/python-torchdata.spec
@@ -13,10 +13,13 @@ Summary: %{pkg_summary}
License: BDS-3-Clause
URL: https://github.com/pytorch/data
Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/data-%{version}.tar.gz
+Source1: aws-sdk-cpp-1fb97256a2ae7211a741fda0033ef1e18d29e2f0.zip
+Source2: pybind11-80dc998efced8ceb2be59756668a7e90e8bef917.zip
BuildRequires: cmake
BuildRequires: ninja-build
BuildRequires: g++
+BuildRequires: unzip
BuildRequires: python3-devel
BuildRequires: python3-setuptools
@@ -39,6 +42,12 @@ Summary: %{pkg_summary}
%prep
%autosetup -p1 -n data-%{pypi_version}
+# unzip and move to third_party/aws-sdk-cpp
+unzip -q %{SOURCE1}
+mv aws-sdk-cpp* third_party/aws-sdk-cpp
+# unzip and move to third_party/pybind11
+unzip -q %{SOURCE2}
+mv pybind11* third_party/pybind11
%build
%pyproject_build