summaryrefslogtreecommitdiff
path: root/python-torchtext.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-03-31 07:52:30 +0000
committerCoprDistGit <infra@openeuler.org>2024-03-31 07:52:30 +0000
commitceb2d2c92d3e75297e0fb756b24146fcfdee5603 (patch)
tree052dd73935aa51a68958b5584cbe55585b7bb056 /python-torchtext.spec
parent3cf5235eb069883d2cbdc37016b5c0a177d0fb7c (diff)
automatic import of python-torchtext
Diffstat (limited to 'python-torchtext.spec')
-rw-r--r--python-torchtext.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/python-torchtext.spec b/python-torchtext.spec
new file mode 100644
index 0000000..013fcce
--- /dev/null
+++ b/python-torchtext.spec
@@ -0,0 +1,49 @@
+%global pypi_name torchtext
+%global pypi_version 0.16.2
+
+Name: python-%{pypi_name}
+Version: %{pypi_version}
+Release: 1%{?dist}
+Summary: Models, data loaders and abstractions for language processing, powered by PyTorch
+
+License: BSD 3-Clause
+URL: https://github.com/pytorch/text
+Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/text-%{version}.tar.gz
+
+BuildRequires: cmake
+
+BuildRequires: python3-tqdm
+BuildRequires: python3-requests
+BuildRequires: python3-nltk
+BuildRequires: python3-spacy
+BuildRequires: python3-sacremoses
+BuildRequires: python3-devel
+
+%description
+Models, data loaders and abstractions for language processing, powered by PyTorch
+
+%package -n python3-%{pypi_name}
+Summary: %{summary}
+
+%description -n python3-%{pypi_name}
+Models, data loaders and abstractions for language processing, powered by PyTorch
+
+%prep
+%autosetup -p1 -n text-%{pypi_version}
+
+rm -rf third_party/*
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{pypi_name}
+%license LICENSE
+%doc README.rst
+%{python3_sitearch}/%{pypi_name}
+
+%changelog
+* Sun Mar 31 2024 YunShu
+- add torchtext