summaryrefslogtreecommitdiff
path: root/python-torchtext.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-torchtext.spec')
-rw-r--r--python-torchtext.spec12
1 files changed, 11 insertions, 1 deletions
diff --git a/python-torchtext.spec b/python-torchtext.spec
index 2a79528..b69f9b3 100644
--- a/python-torchtext.spec
+++ b/python-torchtext.spec
@@ -10,7 +10,16 @@ License: BSD 3-Clause
URL: https://github.com/pytorch/text
Source0: %{url}/archive/refs/tags/v%{version}.tar.gz#/text-%{version}.tar.gz
+Source1: sentencepiece.zip
+
+Patch0: 0001-disable-submodule.patch
+
BuildRequires: cmake
+BuildRequires: ninja-build
+BuildRequires: utf8proc-devel
+BuildRequires: re2-devel
+BuildRequires: double-conversion-devel
+
BuildRequires: python3-tqdm
BuildRequires: python3-requests
@@ -27,9 +36,10 @@ Summary: %{summary}
Models, data loaders and abstractions for language processing, powered by PyTorch
%prep
+unzip -q %{SOURCE1}
%autosetup -p1 -n text-%{pypi_version}
-
rm -rf third_party/*
+mv ../sentencepiece ./third_party/
%build
%py3_build