summaryrefslogtreecommitdiff
path: root/pyporter.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-09-19 17:14:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-09-19 17:14:25 +0000
commit94c9969490aeb68665a57daad2d82615a3368982 (patch)
treedc8590c2cc72a047ad02bf31cae92fa5e7873c5a /pyporter.spec
parent41216cf9843b98fa074e7580679c933d621710e1 (diff)
automatic import of pyporter
Diffstat (limited to 'pyporter.spec')
-rw-r--r--pyporter.spec61
1 files changed, 61 insertions, 0 deletions
diff --git a/pyporter.spec b/pyporter.spec
new file mode 100644
index 0000000..5f65703
--- /dev/null
+++ b/pyporter.spec
@@ -0,0 +1,61 @@
+Name: pyporter
+Version: 1.0
+Release: 2
+Summary: A rpm packager bot for python modules from pypi.org
+License: Mulan PSL v2
+URL: https://gitee.com/openeuler/pyporter
+Source0: https://gitee.com/openeuler/pyporter/repository/archive/v%{version}.tar.gz
+BuildArch: noarch
+%description
+pyporter is a tool to create spec file and create rpm for python modules For more details, please use pyporter -h.
+
+BuildRequires: gcc libstdc++-devel python3-cffi python3-hatchling python3-hatch-vcs openEuler-rpm-config
+Requires: gcc gdb libstdc++-devel python3-cffi
+
+
+%package -n python3-pyporter
+Summary: A rpm packager bot for python modules from pypi.org
+
+%description -n python3-pyporter
+pyporter is a tool to create spec file and create rpm for python modules.
+
+%prep
+%autosetup -n pyporter -p1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+
+%files -n python3-pyporter -f filelist.lst
+%license LICENSE
+%doc README.md
+%dir %{python3_sitelib}/*
+
+
+%changelog
+* Wed Aug 04 2021 chenyanpanHW <chenyanpan@huawei.com> - 1.0-2
+- DESC: delete BuildRequires gdb
+
+* Wed Nov 4 2020 sunchendong<sunchendong@huawei.com> -1.0-1
+- Type:NA
+- ID:NA
+- SUG:NA
+- DESC:init package