summaryrefslogtreecommitdiff
path: root/cephadm-ansible.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-22 15:45:22 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-22 15:45:22 +0000
commit439a3e0e794310f9712f790102d4113a2eea93d9 (patch)
tree11fb4a4f9331d8b2fb964fff89602dad57256180 /cephadm-ansible.spec
parentd6941aa20370e557cf71dfc0441d5a32b08b6c7c (diff)
automatic import of cephadm-ansible
Diffstat (limited to 'cephadm-ansible.spec')
-rw-r--r--cephadm-ansible.spec43
1 files changed, 43 insertions, 0 deletions
diff --git a/cephadm-ansible.spec b/cephadm-ansible.spec
new file mode 100644
index 0000000..47244df
--- /dev/null
+++ b/cephadm-ansible.spec
@@ -0,0 +1,43 @@
+%global commit d3b87c41ec8da5401cb1fc3ef292b0990b7bf953
+%global shortcommit %(c=%{commit}; echo ${c:0:7})
+
+Name: cephadm-ansible
+Version: 1.14.0
+Release: 1%{?dist}
+Summary: ansible playbooks to be used with cephadm
+License: ASL 2.0
+URL: https://github.com/ceph/cephadm-ansible
+Source0: %{name}-%{version}-%{shortcommit}.tar.gz
+
+BuildArch: noarch
+
+BuildRequires: ansible-core >= 2.9
+BuildRequires: ansible-collection-community-general
+Requires: ansible-core >= 2.9
+Requires: ansible-collection-community-general
+
+%description
+cephadm-ansible is a collection of Ansible playbooks to simplify workflows that are not covered by cephadm.
+
+%prep
+%autosetup -p1
+
+%build
+
+%install
+mkdir -p %{buildroot}%{_datarootdir}/cephadm-ansible
+
+for f in ansible.cfg *.yml ceph_defaults library module_utils validate; do
+ cp -a $f %{buildroot}%{_datarootdir}/cephadm-ansible
+done
+
+%check
+ansible-playbook -i tests/functional/hosts cephadm-preflight.yml --syntax-check
+ansible-playbook -i tests/functional/hosts cephadm-purge-cluster.yml -e fsid=%(uuidgen) --syntax-check
+
+%files
+%doc README.md
+%license LICENSE
+%{_datarootdir}/cephadm-ansible
+
+%changelog