summaryrefslogtreecommitdiff
path: root/rqt-py-common.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-08 18:12:24 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-08 18:12:24 +0000
commit3f9d4c59e65db001c48e8325e1f30f83bf2f20e6 (patch)
treec8c5100e9b587d698b3b3e3684a7f2fd83c3e7ff /rqt-py-common.spec
parent918e7757520ea97e5907c0527aacccfde07f288d (diff)
automatic import of ros-humble-rqt-py-commonopeneuler24.03_LTS
Diffstat (limited to 'rqt-py-common.spec')
-rw-r--r--rqt-py-common.spec115
1 files changed, 115 insertions, 0 deletions
diff --git a/rqt-py-common.spec b/rqt-py-common.spec
new file mode 100644
index 0000000..fcdd6f9
--- /dev/null
+++ b/rqt-py-common.spec
@@ -0,0 +1,115 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global debug_package %{nil}
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName rqt-py-common
+%define ros_distro humble
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 1.1.5
+Release: 1%{?dist}%{?release_suffix}
+Summary: ROS rqt-py-common package
+
+Url: http://ros.org/wiki/rqt_py_common
+License: BSD
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: qt5-qtbase-devel
+Requires: ros-%{ros_distro}-rclpy
+Requires: ros-%{ros_distro}-python-qt-binding
+Requires: ros-%{ros_distro}-qt-gui
+Requires: ros-%{ros_distro}-ros-workspace
+
+BuildRequires: qt5-qtbase-devel
+BuildRequires: ros-%{ros_distro}-rclpy
+BuildRequires: ros-%{ros_distro}-ament-cmake
+BuildRequires: ros-%{ros_distro}-ros-workspace
+
+%if 0%{?with_tests}
+BuildRequires: ros-%{ros_distro}-ament-cmake-pytest
+BuildRequires: ros-%{ros_distro}-python-cmake-module
+BuildRequires: ros-%{ros_distro}-rosidl-default-generators
+BuildRequires: ros-%{ros_distro}-rosidl-default-runtime
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+
+ rqt_py_common provides common functionality for rqt plugins written in Python.
+ Despite no plugin is provided, this package is part of the rqt_common_plugins
+ repository to keep refactoring generic functionality from these common plugins
+ into this package as easy as possible.
+
+ Functionality included in this package should cover generic ROS concepts and
+ should not introduce any special dependencies beside "ros_base".
+
+
+%prep
+%autosetup -p1
+
+%build
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+ -UINCLUDE_INSTALL_DIR \
+ -ULIB_INSTALL_DIR \
+ -USYSCONF_INSTALL_DIR \
+ -USHARE_INSTALL_PREFIX \
+ -ULIB_SUFFIX \
+ -DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
+ -DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+ -DBUILD_TESTING=OFF \
+%endif
+ ..
+
+%make_build
+
+%install
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# Look for a Makefile target with a name indicating that it runs tests
+TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
+if [ -n "$TEST_TARGET" ]; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+CTEST_OUTPUT_ON_FAILURE=1 \
+ %make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* Thu May 04 2023 Dorian Scholz scholz@sim.tu-darmstadt.de - 1.1.5-1
+- Autogenerated by ros-porting-tools