summaryrefslogtreecommitdiff
path: root/rqt-gauges.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-27 08:35:48 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-27 08:35:48 +0000
commit0f46423e29f8f7dd25ce69f95a739513824c1055 (patch)
treeecfbc6aeaad2d5a05e2209ce9e23e04f0c43414e /rqt-gauges.spec
parente01f117f56c32ecd6fde0f993e0964b873d6aefe (diff)
automatic import of ros-humble-gauges2openeuler24.03_LTS
Diffstat (limited to 'rqt-gauges.spec')
-rw-r--r--rqt-gauges.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/rqt-gauges.spec b/rqt-gauges.spec
new file mode 100644
index 0000000..61f30cc
--- /dev/null
+++ b/rqt-gauges.spec
@@ -0,0 +1,77 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global debug_package %{nil}
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName rqt-gauges
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 0.0.3
+Release: 1%{?dist}%{?release_suffix}
+Summary: Visualization plugin for several sensors.
+
+License: BSD Clause 3
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-ament-indexpython
+Requires: ros-%{ros_distro}-qt-gui
+Requires: ros-%{ros_distro}-qt-gui-py-common
+Requires: ros-%{ros_distro}-rclpy
+Requires: ros-%{ros_distro}-rqt-gui
+Requires: ros-%{ros_distro}-rqt-gui-py
+
+
+%if 0%{?with_tests}
+BuildRequires: ros-%{ros_distro}-ament-flake8
+BuildRequires: ros-%{ros_distro}-ament-xmllint
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+Visualization plugin for several sensors.
+
+%prep
+%autosetup -p1
+
+%build
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_build
+
+%install
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_install -- --prefix "/opt/ros/%{ros_distro}"
+
+%if 0%{?with_tests}
+%check
+# Look for a directory with a name indicating that it contains tests
+TEST_TARGET=$(ls -d * | grep -m1 "\(test\|tests\)" ||:)
+if [ -n "$TEST_TARGET" ] && %__python3 -m pytest --version; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%__python3 -m pytest $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Eloy Bricneo eloy.briceno@ekumenlabs.com - 0.0.3-1
+- Autogenerated by ros-porting-tools