summaryrefslogtreecommitdiff
path: root/imu-processors.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-04-09 10:20:28 +0000
committerCoprDistGit <infra@openeuler.org>2025-04-09 10:20:28 +0000
commit8c5c4a23449027cdd446d66bdaa3a6d2e6499b6a (patch)
treedae85f37a051f53ba1d5153cb2c0285cf95d1663 /imu-processors.spec
parent8b92cba9062dd234730e494bf703f9925b3180a2 (diff)
automatic import of ros-humble-imu-pipelineopeneuler24.03_LTS
Diffstat (limited to 'imu-processors.spec')
-rw-r--r--imu-processors.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/imu-processors.spec b/imu-processors.spec
new file mode 100644
index 0000000..10dab1a
--- /dev/null
+++ b/imu-processors.spec
@@ -0,0 +1,112 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName imu-processors
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 0.4.1
+Release: 1%{?dist}%{?release_suffix}
+Summary: Processors for sensor_msgs::Imu data
+
+Url: http://ros.org/wiki/imu_processors
+License: BSD
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-geometry-msgs
+Requires: ros-%{ros_distro}-nav-msgs
+Requires: ros-%{ros_distro}-rclcpp
+Requires: ros-%{ros_distro}-rclcpp-components
+Requires: ros-%{ros_distro}-sensor-msgs
+Requires: ros-%{ros_distro}-tf2-ros
+
+BuildRequires: ros-%{ros_distro}-geometry-msgs
+BuildRequires: ros-%{ros_distro}-nav-msgs
+BuildRequires: ros-%{ros_distro}-rclcpp
+BuildRequires: ros-%{ros_distro}-rclcpp-components
+BuildRequires: ros-%{ros_distro}-sensor-msgs
+BuildRequires: ros-%{ros_distro}-tf2-ros
+BuildRequires: ros-%{ros_distro}-ament-cmake
+
+%if 0%{?with_tests}
+BuildRequires: ros-%{ros_distro}-ament-cmake-cpplint
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+Processors for sensor_msgs::Imu data
+
+%prep
+%autosetup -p1
+
+%build
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+export ROS_DISTRO=%{ros_distro}
+export ROS_PYTHON_VERSION=%{python3_version}
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+ -UINCLUDE_INSTALL_DIR \
+ -ULIB_INSTALL_DIR \
+ -USYSCONF_INSTALL_DIR \
+ -USHARE_INSTALL_PREFIX \
+ -ULIB_SUFFIX \
+ -DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
+ -DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_INSTALL_LIBDIR="/opt/ros/%{ros_distro}/lib" \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+ -DBUILD_TESTING=OFF \
+%endif
+ ..
+
+%make_build
+
+%install
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# Look for a Makefile target with a name indicating that it runs tests
+TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
+if [ -n "$TEST_TARGET" ]; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+CTEST_OUTPUT_ON_FAILURE=1 \
+ %make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Paul Bovbel pbovbel@clearpathrobotics.com - 0.4.1-1
+- Autogenerated by ros-porting-tools