summaryrefslogtreecommitdiff
path: root/kobuki-core.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-27 08:35:04 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-27 08:35:04 +0000
commit3acd47044e5192e89bc8b98f372c58efc296c07e (patch)
tree02abdad21041b812b47b9aaa0c75e3284d1eaad8 /kobuki-core.spec
parentb47671a2f7a65ef8992a044186df0240af66e45b (diff)
automatic import of ros-humble-kobuki-coreopeneuler24.03_LTS
Diffstat (limited to 'kobuki-core.spec')
-rw-r--r--kobuki-core.spec122
1 files changed, 122 insertions, 0 deletions
diff --git a/kobuki-core.spec b/kobuki-core.spec
new file mode 100644
index 0000000..4eee13b
--- /dev/null
+++ b/kobuki-core.spec
@@ -0,0 +1,122 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName kobuki-core
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 1.4.1
+Release: 1%{?dist}%{?release_suffix}
+Summary: ROS kobuki-core package
+
+Url: https://kobuki.readthedocs.io/en/release-1.0.x/
+License: BSD
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-ecl-command-line
+Requires: ros-%{ros_distro}-ecl-config
+Requires: ros-%{ros_distro}-ecl-console
+Requires: ros-%{ros_distro}-ecl-converters
+Requires: ros-%{ros_distro}-ecl-devices
+Requires: ros-%{ros_distro}-ecl-geometry
+Requires: ros-%{ros_distro}-ecl-mobile-robot
+Requires: ros-%{ros_distro}-ecl-sigslots
+Requires: ros-%{ros_distro}-ecl-threads
+Requires: ros-%{ros_distro}-ecl-time
+
+BuildRequires: ros-%{ros_distro}-ecl-build
+BuildRequires: ros-%{ros_distro}-ecl-command-line
+BuildRequires: ros-%{ros_distro}-ecl-config
+BuildRequires: ros-%{ros_distro}-ecl-console
+BuildRequires: ros-%{ros_distro}-ecl-converters
+BuildRequires: ros-%{ros_distro}-ecl-devices
+BuildRequires: ros-%{ros_distro}-ecl-geometry
+BuildRequires: ros-%{ros_distro}-ecl-mobile-robot
+BuildRequires: ros-%{ros_distro}-ecl-sigslots
+BuildRequires: ros-%{ros_distro}-ecl-threads
+BuildRequires: ros-%{ros_distro}-ecl-time
+BuildRequires: ros-%{ros_distro}-ament-cmake-ros
+
+%if 0%{?with_tests}
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+
+ Pure C++ driver library for Kobuki.
+
+
+%prep
+%autosetup -p1
+
+%build
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+export ROS_DISTRO=%{ros_distro}
+export ROS_PYTHON_VERSION=%{python3_version}
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+ -UINCLUDE_INSTALL_DIR \
+ -ULIB_INSTALL_DIR \
+ -USYSCONF_INSTALL_DIR \
+ -USHARE_INSTALL_PREFIX \
+ -ULIB_SUFFIX \
+ -DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
+ -DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_INSTALL_LIBDIR="/opt/ros/%{ros_distro}/lib" \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+ -DBUILD_TESTING=OFF \
+%endif
+ ..
+
+%make_build
+
+%install
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# Look for a Makefile target with a name indicating that it runs tests
+TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
+if [ -n "$TEST_TARGET" ]; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+CTEST_OUTPUT_ON_FAILURE=1 \
+ %make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Daniel Stonier d.stonier@gmail.com - 1.4.1-1
+- Autogenerated by ros-porting-tools